Closed Bug 598391 Opened 9 years ago Closed 9 years ago

Page does not update and panning/clicking is incorrect after scrolling by content

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

defect
Not set

Tracking

(fennec2.0b1+)

VERIFIED FIXED
Tracking Status
fennec 2.0b1+ ---

People

(Reporter: mbrubeck, Assigned: stechz)

References

Details

Attachments

(3 files, 1 obsolete file)

Attached file test case
Steps to reproduce:
1. Open the attached test case.
2. Click on "test 1" which uses href=#bottom, or "test 2" which uses scrollTo.

Expected results:  The page pans to the bottom, where you can see the text "bottom"

Actual results: The page fail to repaint (gray screen), and you can still get a tap highlight or contextmenu by tapping on the screen where the "test 1" and "test 2" links used to be.
Blocks: 598234
tracking-fennec: --- → ?
Comment on attachment 477228 [details] [diff] [review]
listen for scroll events

There still seems to be a platform bug, looking into it.
Attachment #477228 - Flags: review?(mbrubeck)
Depends on: 598439
Comment on attachment 477228 [details] [diff] [review]
listen for scroll events

The code is fine here, though it's hard to tell if it's correct until we pin down the platform behavior.
Attachment #477228 - Flags: review?(mbrubeck) → review+
Assignee: nobody → webapps
With the dependency bug, things seems to work perfectly.
I noticed one problem with these patches: If the urlbar or sidebars are showing when the scroll happens, then they remain there after the scroll, even if the page scrolls away from the top or sides.

Here's a fix for that problem.
Attachment #477528 - Flags: review?(webapps)
Comment on attachment 477528 [details] [diff] [review]
part 2: Hide browser chrome on scroll

r+ (without the dump of course)
Attachment #477528 - Flags: review?(webapps) → review+
Attachment #477528 - Attachment is obsolete: true
Attachment #477534 - Flags: review+
tracking-fennec: ? → 2.0b1+
No longer blocks: 598234
http://hg.mozilla.org/mobile-browser/rev/f013636c46bd
http://hg.mozilla.org/mobile-browser/rev/53e27f03c0bc
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
verified FIXED on builds:

Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b6pre) Gecko/20100924 Namoroka/4.0b7pre Fennec/2.0b1pre

and

Mozilla/5.0 (Android; Linux armv71; rv:2.0b6pre) Gecko/20100924 Namoroka/4.0b7pre Fennec/2.0b1pre
Status: RESOLVED → VERIFIED
Depends on: 621066
You need to log in before you can comment on or make changes to this bug.