GCAutoEnter::SetGCToNull needs attention

VERIFIED WONTFIX

Status

P1
normal
VERIFIED WONTFIX
8 years ago
8 years ago

People

(Reporter: stejohns, Assigned: treilly)

Tracking

unspecified
flash10.2.x-Spicy
Bug Flags:
flashplayer-qrb +

Details

(Reporter)

Description

8 years ago
This is needed for some Android builds, but has not landed in avmplus.
See bug 590112, comment 3

The reason I noted there that this is not the right long-term solution is because Tommy thinks we need to investigate why the Android team was doing this in the first place.  It may have been a work-around for a bug in their code, but not a real fix.  We don't know yet.
(Reporter)

Comment 2

8 years ago
According to Samuli and Brent, the genesis of this was: "Ultimately, the memory manager is not designed to handle destruction of the GC while it's entered multiple times on the stack.  Modifying the code to handle this would be a large design change, and I'm not sure it's something we really want to support anyway. Samuli has a band-aid fix for this that handles this special case by forcing the stackEnter gc to NULL and long jumping to before the original stack enter.  This seems like a feasible workaround for this edge case."
(Assignee)

Comment 3

8 years ago
Hurmph, I hate it when we have a fix and don't have a complete understanding of the problem, I'll try to remedy that.
Assignee: nobody → treilly
Status: NEW → ASSIGNED

Updated

8 years ago
Flags: flashplayer-qrb+
Priority: -- → P2
Target Milestone: --- → flash10.2.x-Spicy
Duplicate of this bug: 590112

Updated

8 years ago
Priority: P2 → P1
(Assignee)

Comment 5

8 years ago
The need for this hasn't been adequately demonstrated despite repeated attempts at explaining why it shouldn't be necessary and asking for more information.    Resolving as wont fix.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX

Comment 6

8 years ago
bulk verifying resolved !fixed issues
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.