Current fullscreen exits at bad times - need a "lock fullscreen" feature.

RESOLVED INVALID

Status

()

Firefox
General
--
enhancement
RESOLVED INVALID
8 years ago
3 years ago

People

(Reporter: Kevin Ar18, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0b5pre) Gecko/20100824 Minefield/4.0b5pre
Build Identifier: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0b5pre) Gecko/20100824 Minefield/4.0b5pre

The current fullscreen causes major issues with web games (flash or html) in that it exits prematurely.  An option to "lock" fullscreen mode would be desirable.

Reproducible: Always

Steps to Reproduce:
1. Navigate to a .swf link or a fullscreen html game.
2. Switch to fullscreen mode in Firefox.
3. Move your mouse to the top of the screen while playing the game.
Actual Results:  
The address bar or some other menu slides down and messes up your game.  You cannot play games fullscreen without risking messing up many times.

Expected Results:  
If Firefox had a "lock" mode, then nothing would happen - no menu would slide out.

I do think this feature has big implications for gaming using the browser.

The is not suggesting a permanent Kiosk mode.  Instead, what I have in mind is that you can only exit fullscreen using some very specific commands.

I'm not sure of the best way to work it into the UI, but here's the general concept.

1. When you enter the "locked fullscreen" mode, the user is presented with a dialog that tells them how they can exit fullscreen (perhaps by pressing "Alt+Enter" or "F11" or ?).  Note: "Alt+Enter" seems like a good key combo since it is the common method for exiting fullscreen in many apps.
2. Alternatively, the dialog could present the option not to enter the locked mode.
3. Other OS specific keys would still exit fullscreen (windows key, alt-tab in Windows, Alt+F4, Alt+Enter etc...).


Note Bug 462628 could offer a solution; however, I feel that this issue is important enough for the general public to include as a more prominent preference or feature.
The game now can use the Fullscreen API [1] to enter fullscreen where no browser UI should accidentally appear. Close this bug as INVALID.

[1] https://developer.mozilla.org/en-US/docs/Web/Guide/API/DOM/Using_full_screen_mode
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.