Closed Bug 598578 Opened 9 years ago Closed 9 years ago

Crash [@ PL_DHashTableOperate | nsTHashtable<nsBaseHashtableET<nsUint32HashKey, nsCOMPtr<nsILocalFile> > >::RemoveEntry(unsigned int const&) ]

Categories

(Core :: Disability Access APIs, defect, critical)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla5
Tracking Status
blocking2.0 --- .x+

People

(Reporter: MarcoZ, Assigned: surkov)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file, 1 obsolete file)

STR:
1. Start NVDA, then Minefield.
2. Shutdown NVDA.
3. Start JAWS.
4. Because JAWS doesn't see a virtual buffer, because window emulation isn't enabled, shut down Minefield.

Result: Crashes like this: bp-043a8803-729a-4a1b-ba2a-f16f22100922
I can't reproduce on nightly, can you?
Yes, I can still see crashes when forgetting to shut down Minefield when I alternate between JAWS and NVDA.
One is: https://crash-stats.mozilla.com/report/index/046f0ef3-6011-4aca-8a17-1bd072110310
(In reply to comment #2)
> Yes, I can still see crashes when forgetting to shut down Minefield when I
> alternate between JAWS and NVDA.
> One is:
> https://crash-stats.mozilla.com/report/index/046f0ef3-6011-4aca-8a17-1bd072110310

Oh that's the new code to remove the HWND...
nsAccessibleWrap::sHWNDCache.Remove(mHWND)
Attached patch patch (obsolete) — Splinter Review
Assignee: nobody → surkov.alexander
Status: NEW → ASSIGNED
Attachment #518622 - Flags: review?(bolterbugz)
Attachment #518622 - Flags: feedback?(marco.zehe)
Comment on attachment 518622 [details] [diff] [review]
patch

f=me. This patch makes the crashes go away.
Attachment #518622 - Flags: feedback?(marco.zehe) → feedback+
Comment on attachment 518622 [details] [diff] [review]
patch

r=me
Attachment #518622 - Flags: review?(bolterbugz) → review+
should we take it into fx4.x?
(In reply to comment #8)
> should we take it into fx4.x?

I think so, it is a reproducible crasher.
blocking2.0: --- → ?
Note to drivers:

Since this change only affects the case where specific screen readers are used, and we can engage community testers it makes sense that this is low risk enough for .x to me.
blocking2.0: ? → .x+
Whiteboard: [FF5]
Attached patch patch to landSplinter Review
Attachment #518622 - Attachment is obsolete: true
Whiteboard: [fx4-rc-ridealong][has reviewed patch]
landed - http://hg.mozilla.org/mozilla-central/rev/56c7c8c7aeb4
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [fx4-rc-ridealong][has reviewed patch]
Target Milestone: --- → mozilla2.2
Duplicate of this bug: 645670
Crash Signature: [@ PL_DHashTableOperate | nsTHashtable<nsBaseHashtableET<nsUint32HashKey, nsCOMPtr<nsILocalFile> > >::RemoveEntry(unsigned int const&) ]
You need to log in before you can comment on or make changes to this bug.