If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Nothing should happen when clicking on a <menuseparator/> (text fields only)

VERIFIED WORKSFORME

Status

()

Core
XUL
P3
trivial
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Blake Ross, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({helpwanted, polish})

Trunk
Future
helpwanted, polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build ID: new trunk

Steps to Reproduce:

(1) Right click on the URL bar.
(2) Right click on the separator above "Select All" in the context menu that 
appears.

Assuming the menu extended over the content area (as it did for me), right 
clicking on the separator closes the menu and opens another editor context menu 
in the new spot where you clicked.  In another words, the click went through. 
The convention (on Windows) is that left- or right-clickign on a menu separator 
does nothing (and the menu remains open).
(Reporter)

Comment 1

17 years ago
oh, hrm...only happens with the xul textfield context menus.  not sure whose 
bug this is now.
(Assignee)

Comment 2

17 years ago
trivial
Severity: normal → trivial
Status: NEW → ASSIGNED
Keywords: helpwanted, polish
Summary: Nothing should happen when clicking on a <menuseparator/> → Nothing should happen when clicking on a <menuseparator/> (text fields only)
Target Milestone: --- → Future

Comment 3

17 years ago
Blake, do you still see this?  I don't.
(Reporter)

Comment 4

17 years ago
Yep, works for me also.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 5

17 years ago
vfy
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.