The default bug view has changed. See this FAQ.

Add longhand transform properties for ease of use

RESOLVED WONTFIX

Status

()

Core
CSS Parsing and Computation
--
enhancement
RESOLVED WONTFIX
7 years ago
5 years ago

People

(Reporter: Sam Shull, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 (.NET CLR 3.5.30729)
Build Identifier: 

-moz-transform should be extended with additional longhand properties similar to all other CSS modules. Such that each of the supported transform functions should be accessible in a separate property, examples:

-moz-transform-scale-x: .3;
-moz-transform-scale-y: .6;
-moz-transform-rotate: 30deg;
-moz-transform-translate: 10%, 12px;
...etc...

This would be in keeping with the traditional CSS syntax and make extending transform easier for the user.


Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. Add properties to CSS declarations block
2. Properties are included in the rendering of the style for the selected element(s)
Actual Results:  
Nothing

Expected Results:  
Element is transformed using transform functions from existing implementation
This sounds like a nightmare, since the meaning of this:

  transform: translate(12px) rotate(30deg);

and this:

  transform: rotate(30deg) translate(12px);

is different.  So are you proposing that the order of the longhands would affect the result?  That's pretty broken in terms of how the rest of CSS works, and not at all in keeping with "traditional CSS syntax".
Component: General → Style System (CSS)
QA Contact: general → style-system
(Reporter)

Comment 2

7 years ago
By "traditional CSS syntax" I mean in the same syntax as 

border-top-width: 10px;

 and 

border-bottom-width: 5px; 

And yes I understand that functions are to be applied in the order in which they are given. Would that not be similar to overriding a property that existed before? Such as overriding a color with an rgba if rgba is supported:

#id {
color: #080808;
color: rgba(8,8,8,.8);
}
That's not the same thing.  Conceptually, CSS declarations are just an unordered set of longhands after parsing; parsing simply throws away the old value and uses the new one if you parse the same property twice.

You're suggesting totally changing the conceptual model of CSS declarations, on the other hand, since now the order of different unrelated longhands would matter.
I also don't think this makes sense.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 548378
You need to log in before you can comment on or make changes to this bug.