font issues in Firefox Mac, FF Win is fine.

RESOLVED DUPLICATE of bug 493583

Status

()

RESOLVED DUPLICATE of bug 493583
8 years ago
8 years ago

People

(Reporter: seth, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 FirePHP/0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 FirePHP/0.4

I am working on a "countdown" clock and in all browser, even IE, the layout matches relatively close.  In Firefox on Mac 3.6.10 acts very strange.  I've tested in IE7, Chrome (mac/pc), Safari (mac/pc), Firefox (mac/pc) and the Mac version of FF is the only version that I can tell with the issue.

font:bold 75px Helvetica, Arial, sans-serif;

That's the line of CSS that caused the issue.

Reproducible: Always

Steps to Reproduce:
1. Add font property
2. Save
3. Watch the magic
Actual Results:  
Magic.

Expected Results:  
The font should be positioned lower as in all other browsers.  Even setting line-height has the same 6px difference.

Comment 1

8 years ago
Opera Mac (checked with 10.6 and 10.7a) displays the same as Gecko. The thing is, Arial and Helvetica have different metrics. But WebKit has a hack built in to force Helvetica to use the metrics of Arial
http://lists.w3.org/Archives/Public/www-style/2008Jan/0330.html

If you change your stylesheet from 'Helvetica' to 'Helvetica Neue', you will see that the text positioning is identical across different browsers on OS X.

(see also bug 480196)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 493583
You need to log in before you can comment on or make changes to this bug.