SurfaceVRam reporting is wrong for interop

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: bas, Assigned: bas)

Tracking

unspecified
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 beta7+)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Created attachment 477552 [details] [diff] [review]
Fix memory counting with interop

The surface VRAM memory usage reported when using interop is wrong. When an interop D2D surface is destroyed it does decrement the memory counter, but it does not increment it when it is created.
Attachment #477552 - Flags: review?(joe)
(Assignee)

Updated

7 years ago
Attachment #477552 - Flags: approval2.0?
Comment on attachment 477552 [details] [diff] [review]
Fix memory counting with interop

We should probably not release Beta 7 without this, because it'll make debugging problems people have harder.
Attachment #477552 - Flags: review?(joe)
Attachment #477552 - Flags: review+
Attachment #477552 - Flags: approval2.0?
blocking2.0: --- → beta7+
(Assignee)

Comment 2

7 years ago
http://hg.mozilla.org/mozilla-central/rev/828b362466c1
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Duplicate of this bug: 593616
You need to log in before you can comment on or make changes to this bug.