username is validated against mozilla servers when "custom server" is selected

RESOLVED WONTFIX

Status

Cloud Services
Firefox Sync: UI
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: atoll, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Steps to reproduce on FF 4b6:

1. Set up sync for the first time.  Select "I have never synced".
2. At the "Create your sync account" screen, select "Use a custom server" from the "Connect to" dropdown.
3. Type the letter "a" into the "User Name" field.  Move the cursor to any other field.
BUG: Firefox will display (x) Already in use.

At this stage, there is no sync server defined, so Firefox is incapable of knowing that the username "a" is already taken, since I haven't specified a sync server yet.

My theory is that, lacking a sync server definition, it is checking the username against the Firefox Sync servers.  The username "a" is indeed taken in production, but not in stage or dev.

Perhaps a potential data privacy issue with people's usernames being sent to us when they specifically intend otherwise.
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [needs verification]
QA, is this still a problem?
Keywords: qawanted
yes, this still occurs. "a" is no longer valid, But I did use a known live account to test against.  

Note: this occurs if you have selected but have yet to enter a valid custom server URL.  If you enter a valid custom server, username (now Email Address) validation works against the custom server.
Keywords: qawanted

Updated

5 years ago
Whiteboard: [needs verification]
This bug only likely affects Sync 1.1, and it was shut down in the fall of 2015 (https://blog.mozilla.org/services/2015/07/31/shutting-down-the-legacy-sync-service/).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.