Closed Bug 598831 Opened 9 years ago Closed 9 years ago

Liquid Particles Chrome Experiment runs much slower on Minefield than on Chromium, no hardware acceleration

Categories

(Core :: Canvas: 2D, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 564643

People

(Reporter: sweerdenburg, Unassigned)

References

()

Details

(Whiteboard: [chromeexperiments])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.13) Gecko/20100914 Firefox/3.5.13
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100921 Firefox/4.0b7pre

Chrome Experiment "Liquid particles" runs extremely slow compared to chrome without hardware acceleration enabled. Chromium provides fluid animation on particles, while Minefield runs approximately 10 fps. Scenario "Liquid letters" runs equally slow on both, regardless of hardware acceleration 

Reproducible: Always

Steps to Reproduce:
1. Load the web page
2. Click around to manipulate the particles
Actual Results:  
Very slow redraw rate compared to chromium nightly.

Expected Results:  
Ideally, Chromium and Minefield should be equal speeds.

No noticeable difference when hardware acceleration is off
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [chromeexperiments]
(In reply to comment #0)

> Chrome Experiment "Liquid particles" runs extremely slow compared to chrome
> without hardware acceleration enabled.

> No noticeable difference when hardware acceleration is off

So, I don't understand. The two above sentences seem to be contradictory. Is it with or without HW acceleration, that you noticed a large speed difference between chromium and minefield?

Also, it's always useful to include the name of your graphics card and driver version.
Sorry. There is no noticeable difference in "Liquid Letters" regardless of hardware acceleration or browser. Liquid particles is slower than chrome without hardware acceleration, but there is no noticeable difference between minefield and chromium with hardware acceleration on

Here's my graphics info:

Adapter: NVIDIA GeForce 9300 GE
Driver version: 8.17.12.5896
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 564643
You need to log in before you can comment on or make changes to this bug.