Last Comment Bug 598859 - 379105-1.xhtml | assertion count 3 is more than expected 0 assertions
: 379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2010-09-22 23:41 PDT by Josh Aas
Modified: 2012-11-25 19:31 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
snippet from the most recent tinderbox log (4.45 KB, text/plain)
2010-10-10 08:47 PDT, Jesse Ruderman
no flags Details

Description Josh Aas 2010-09-22 23:41:39 PDT

    
Comment 1 Josh Aas 2010-09-22 23:42:41 PDT
WINNT 5.2 mozilla-central debug test crashtest on 2010/09/22 23:02:56
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1285221776.1285222755.669.gz
Comment 2 Treeherder Robot 2010-10-04 21:31:48 PDT
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1286251894.1286252737.9979.gz
WINNT 5.2 tracemonkey debug test crashtest on 2010/10/04 21:11:34

s: win32-slave17
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/tracemonkey-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 3 Treeherder Robot 2010-10-06 21:11:28 PDT
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1286423216.1286424078.15733.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/10/06 20:46:56

s: win32-slave29
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 4 Jesse Ruderman 2010-10-10 08:47:11 PDT
Created attachment 482141 [details]
snippet from the most recent tinderbox log
Comment 5 Jesse Ruderman 2010-10-10 08:47:46 PDT
###!!! ASSERTION: No Document Request!: 'mDocumentRequest', file uriloader/base/nsDocLoader.cpp, line 789

###!!! ASSERTION: Firing OnStateChange(...) notification with a NULL request!: 'aRequest', file uriloader/base/nsDocLoader.cpp, line 1306
Comment 6 Jesse Ruderman 2010-10-10 08:50:16 PDT
Other bugs with these assertions: bug 479160, bug 570215.
Comment 7 Treeherder Robot 2010-10-17 00:18:53 PDT
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1287262692.1287263603.29539.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/10/16 13:58:12

s: win32-slave44
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 8 Treeherder Robot 2010-10-17 22:59:49 PDT
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1287363230.1287367741.30800.gz
WINNT 5.2 tracemonkey debug test crashtest on 2010/10/17 17:53:50

s: win32-slave35
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/tracemonkey-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 9 Treeherder Robot 2010-10-18 14:13:46 PDT
mounir.lamouri%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1287425886.1287426848.450.gz
WINNT 5.2 tryserver debug test crashtest on 2010/10/18 11:18:06

s: try-w32-slave09
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/tryserver-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 10 Treeherder Robot 2010-10-19 19:18:25 PDT
birtles%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1287539698.1287540638.9881.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/10/19 18:54:58

s: win32-slave02
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 11 Treeherder Robot 2010-10-22 10:48:46 PDT
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1287768599.1287769421.18480.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/10/22 10:29:59

s: win32-slave40
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 12 Treeherder Robot 2010-10-25 20:53:12 PDT
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1288064065.1288064905.8963.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/10/25 20:34:25

s: win32-slave34
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 13 Treeherder Robot 2010-10-26 18:45:43 PDT
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1288142352.1288143187.16726.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/10/26 18:19:12

s: win32-slave36
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 14 Treeherder Robot 2010-10-27 18:01:35 PDT
dwitte%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1288218800.1288219804.22228.gz
WINNT 5.2 tryserver debug test crashtest on 2010/10/27 15:33:20

s: try-w32-slave12
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/tryserver-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 15 Treeherder Robot 2010-10-28 03:29:56 PDT
surkov.alexander%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1288260717.1288261508.3754.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/10/28 03:11:57

s: win32-slave30
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 16 Treeherder Robot 2010-10-28 03:30:16 PDT
mak77%bonardo.net
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1288260717.1288261508.3754.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/10/28 03:11:57

s: win32-slave30
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 17 Treeherder Robot 2010-10-28 06:33:51 PDT
mak77%bonardo.net
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1288264905.1288265936.32228.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/10/28 04:21:45

s: win32-slave45
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 18 Treeherder Robot 2010-10-28 16:12:29 PDT
josh%joshmatthews.net
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1288304904.1288306008.24495.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/10/28 15:28:24

s: win32-slave32
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/272647-1.html | timed out waiting for onload to fire
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 19 Treeherder Robot 2010-11-01 17:22:51 PDT
rstrong%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1288655630.1288657038.10030.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/11/01 16:53:50

s: win32-slave37
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 20 Treeherder Robot 2010-11-01 17:23:31 PDT
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1288655630.1288657038.10030.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/11/01 16:53:50

s: win32-slave37
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 21 Treeherder Robot 2010-11-04 04:59:47 PDT
dao%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1288859968.1288860881.13795.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/11/04 01:39:28

s: win32-slave26
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 22 Treeherder Robot 2010-11-05 15:11:35 PDT
margaret.leibovic%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1288994349.1288994921.7642.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/11/05 14:59:09

s: mw32-ix-slave05
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 23 Treeherder Robot 2010-11-06 14:28:00 PDT
joshmoz%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1289077163.1289078070.14566.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/11/06 13:59:23

s: win32-slave25
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/379105-1.xhtml | assertion count 3 is more than expected 0 assertions
Comment 24 Jesse Ruderman 2010-11-06 14:55:21 PDT
Same ingredients as bug 570215 and bug 479160, namely frames+XBL.  So probably the same bug.  And since it uses XBL and timers, it's completely understandable for it to be intermittent.

--> http://hg.mozilla.org/mozilla-central/rev/9500a7491002
Comment 25 Treeherder Robot 2012-06-15 23:29:24 PDT
capella
https://tbpl.mozilla.org/php/getParsedLog.php?id=12721721&tree=Try
Android Tegra 250 try opt test crashtest-2 on 2012-06-15 22:32:57
slave: tegra-087

REFTEST TEST-UNEXPECTED-FAIL | http://10.250.48.211:30087/tests/layout/base/crashtests/379105-1.xhtml | load failed: timed out waiting for reftest-wait to be removed
REFTEST TEST-UNEXPECTED-FAIL | http://10.250.48.211:30087/tests/layout/base/crashtests/645572-1.html | load failed: timed out waiting for reftest-wait to be removed

Note You need to log in before you can comment on or make changes to this bug.