SOGo calendar keeps reloading every few seconds (upgrade 1.0b1->1.0b2)

RESOLVED WORKSFORME

Status

Calendar
Provider: CalDAV
RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: Hannes Erven, Unassigned)

Tracking

Lightning 1.0b2
x86
Linux

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.9) Gecko/20100923 Lightning/1.0b2 Thunderbird/3.1.3

I upgraded from tb-3.0.4-r1 to 3.1.3 / lightning 1.0b1 to 1.0b2 tonight. The problem started today, so it seems to be related to the 1.0b1->1.0b2 upgrade.

My config includes one HTTP ICS file (Mozilla holidays) and 4 SOGO Calendars from my SOGO server (https://).
The calendars all load and are displayed, but Lightning keeps reloading one(!) of the calenders. This occurs about every 1-3 seconds, triggers a flickering repaint of the calendar view and spends lots of CPU.

The tb event log contains only this interesting line:

Fehler: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsISAXXMLReader.onDataAvailable]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: file:///home/hannes/.thunderbird/p4thks6e.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/hannes/.thunderbird/p4thks6e.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js :: wSL_onDataAvailable :: line 482"  data: no]
Quelldatei: file:///home/hannes/.thunderbird/p4thks6e.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/hannes/.thunderbird/p4thks6e.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js
Zeile: 482

Then there are a few reports about unknown timezones (mostly on events I was invited from e.g. Lotus Notes), and that's it. The console does not display any sign of the constant reloading.

The "Automatic calendar reloading" preference is deactivated and set to 10000 minutes.


The sogo server log contains:

[23/Sep/2010:10:27:13 +0200] "REPORT /SOGo/dav/ HTTP/1.1" 401 -
[23/Sep/2010:10:27:13 +0200] "REPORT /SOGo/dav/ HTTP/1.1" 401 -
[23/Sep/2010:10:27:14 +0200] "REPORT /SOGo/dav/ HTTP/1.1" 401 -
[23/Sep/2010:10:27:14 +0200] "REPORT /SOGo/dav/ HTTP/1.1" 401 -
[23/Sep/2010:10:27:14 +0200] "REPORT /SOGo/dav/ HTTP/1.1" 207 613
[23/Sep/2010:10:27:14 +0200] "REPORT /SOGo/dav/ HTTP/1.1" 207 613
[23/Sep/2010:10:27:14 +0200] "REPORT /SOGo/dav/ HTTP/1.1" 207 613
[23/Sep/2010:10:27:14 +0200] "REPORT /SOGo/dav/ HTTP/1.1" 207 613
[23/Sep/2010:10:27:14 +0200] "REPORT /SOGo/dav/hannes/Calendar/7C74-4B968880-DC5-141AFC40/ HTTP/1.1" 207 6234
[23/Sep/2010:10:27:14 +0200] "REPORT /SOGo/dav/hannes/Calendar/ulli_7C74-4B968980-E6D-141AFC40/ HTTP/1.1" 207 55172
[23/Sep/2010:10:27:14 +0200] "REPORT /SOGo/dav/hannes/Calendar/7C74-4B968700-7F9-141AFC40/ HTTP/1.1" 207 62212
[23/Sep/2010:10:27:14 +0200] "REPORT /SOGo/dav/hannes/Calendar/7C74-4B968200-1-141AFC40/ HTTP/1.1" 207 106474
[23/Sep/2010:10:27:30 +0200] "REPORT /SOGo/dav/hannes/Calendar/inbox/ HTTP/1.1" 403 95
[23/Sep/2010:10:27:30 +0200] "REPORT /SOGo/dav/hannes/Calendar/ulli_7C74-4B968980-E6D-141AFC40/ HTTP/1.1" 207 55172
[23/Sep/2010:10:27:34 +0200] "REPORT /SOGo/dav/hannes/Calendar/inbox/ HTTP/1.1" 403 95
[23/Sep/2010:10:27:34 +0200] "REPORT /SOGo/dav/hannes/Calendar/ulli_7C74-4B968980-E6D-141AFC40/ HTTP/1.1" 207 55172
[23/Sep/2010:10:27:37 +0200] "REPORT /SOGo/dav/hannes/Calendar/inbox/ HTTP/1.1" 403 95
[23/Sep/2010:10:27:37 +0200] "REPORT /SOGo/dav/hannes/Calendar/ulli_7C74-4B968980-E6D-141AFC40/ HTTP/1.1" 207 55172
[23/Sep/2010:10:27:40 +0200] "REPORT /SOGo/dav/hannes/Calendar/inbox/ HTTP/1.1" 403 95
[23/Sep/2010:10:27:40 +0200] "REPORT /SOGo/dav/hannes/Calendar/ulli_7C74-4B968980-E6D-141AFC40/ HTTP/1.1" 207 55172
[23/Sep/2010:10:27:43 +0200] "REPORT /SOGo/dav/hannes/Calendar/inbox/ HTTP/1.1" 403 95


The calendar that is being constantly reloaded is the ONLY one in my config where the SOGO calendar is owned by another sogo user ("ulli" in this case).

Unchecking that calendar in the view has no effect. Disabling the calendar stops the reloading.

I'd tried the nightly build, but it is not compatible with the TB version. Since it appears to be a regression to 1.0b1 I decided to keep the current versions, but if that helps I sure can try any other tb/lightning version.

Thanks for your efforts!

Reproducible: Always

Steps to Reproduce:
1. Start TB
2. Enter Authentication Data
3. watch reloading...
(Reporter)

Comment 1

7 years ago
Additional info 1: I tried with 1.0b3pre for tb3.1 , same issue.

Additional info 2: The reloading does not stop immediately when I disable the affected calendar, only after a tb-restart.
Version: unspecified → Lightning 1.0b2
We might have fixed this bug in the meanwhile, could you test 1.0b4pre with a Thunderbird 3.3 Alpha/Beta?
I believe this has been fixed, please reopen if its not the case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.