problem with cached object - 304 shows as 404

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: Jack Eidsness, Unassigned)

Tracking

4.0 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100923 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100923 Firefox/4.0b7pre

This happened immediately after today's minefield update.  When the browser restarted and displayed my previous session, an image was replaced by alt text, and upon further inspection, that image is wrongly showing as a 404.  I verified that the file is there on the server.

Reproducible: Couldn't Reproduce

Actual Results:  
I've only seen this once so far, but the request is going out as if the cached object were available, but when the 304 is returned, it displays a 404.

Expected Results:  
1) It shouldn't send an "If-none-match" or "If-Modified-Since" if the object can't be retrieved from the cache.
2) Failing that, I'd rather it didn't say "File not Found" as if it were a 404, when that's clearly not what came out of the server.

I'm attaching a picture that shows it all, with headers.
(Reporter)

Comment 1

8 years ago
Created attachment 477910 [details]
headers and "not found" message

Comment 2

8 years ago
Same problem here, with Firefox 4.0 beta 5 and 6 (Linux x86_64). Browser makes HTTP request propertly and a 304 header is returned, but error page is shown. I tryied to delete cache and works OK, but problem appears again randomly. Seems like Firefox doesn't find cache file.

Comment 3

7 years ago
I am getting this issue intermittently on Firefox 4.0.1 at http://www.sfmta.com/cms/home/sfmta.php with regard to the large image having the ID top1right.  The image intermittently comes up blank.  If I then view source and find the first occurrence of /home/images and change the URL to http://www.sfmta.com/cms/home/images/[whatever the image filename is] e.g. http://www.sfmta.com/cms/home//images/SFMTA-Diversity-WebHome4-461x168.jpg, I get the following page:

File not found
Firefox can't find the file at http://www.sfmta.com/cms/home/images/SFMTA-Diversity-WebHome4-461x168.jpg.
Check the file name for capitalization or other typing errors.
Check to see if the file was moved, renamed or deleted.

Pressing the Try Again button repeatedly will eventually load the image.

I have confirmed that the actual status code is 304 not 404.

Updated

7 years ago
Version: unspecified → 4.0 Branch
This bug was reported using a pre-release version of Firefox 4. Now that Firefox 4.0.1 final has been released, can you please update and retest your bug? A fresh profile would be a good starting place to test, 
http://support.mozilla.com/kb/Managing+profiles. If you continue to see the issue, can you please update this bug with your results?

Filter: firefox4prebugsunco

Comment 5

7 years ago
I was getting it in Firefox 4.0.1 on Windows XP SP3.  I tried with a fresh profile and am at the moment unable to reproduce it.  However, I'm not able to reproduce it right now on my regular profile either.  So, I'd say at the moment the bug seems to have mysteriously disappeared. 

Since I was getting it on 4.0.1 before, that implies some kind of change in the environment.  One change I know of is that I'm clearing out my cache a lot more often due to an apparent bug in Twitter that prevents content from loading when I have a full cache.  However, even dropping my cache on the new profile to 1MB, I was unable to reproduce the problem.

Comment 6

5 years ago
still see this?
Flags: needinfo?(jack)
(Reporter)

Comment 7

5 years ago
It was a pretty rare event, and I couldn't deliberately reproduce it even then, but I think I did see it a few times within a few months, and now it's been years since I thought of this. It probably got fixed or entirely replaced for unrelated reasons.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(jack)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.