Closed Bug 598954 Opened 11 years ago Closed 11 years ago

"Find in This Message" Does Not Work for Newsgroup Messages

Categories

(Thunderbird :: Search, defect)

x86
All
defect
Not set
major

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 564328

People

(Reporter: david, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.13) Gecko/20100914 SeaMonkey/2.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100915 Thunderbird/3.1.4

I tried to find a word in the body of a long newsgroup message, a word that I knew was there (possibly more than once).  The result was a different message with that word in the subject.  

Reproducible: Always

Steps to Reproduce:
1.  Open a newsgroup message.  

2.  Choose a word in the body of the message that does not appear in the subject line but does appear in the subject lines of other messages.  

3.  On the Thunderbird menu bar, select [Edit > Find > Find in This Message].  

4.  Click on the message body in the Message pane to make sure it is selected.  

5.  In the search input area, enter the chosen word.  Do NOT select the Enter key.  
Actual Results:  
The Header pane will show the messages that contain the chosen word in their subject lines.  

Expected Results:  
Nothing should happen until the Enter key is used.  Then the chosen word should be highlighted in the Message pane.  

I tested this in Safe mode with [View > Layout > Wide View].  The message I had opened disappeared from the Message pane when I completed entering my chosen word.  I got the same result using Ctrl-F.  

Since I had set [View > Threads > Threads with Unread] and the message I wanted to search was the last unread in that newsgroup, when I closed the Quick Filter bar, the Header pane was blank.  

I have not tested this problem with E-mail messages.  It might also be an E-mail problem.  

It appears that there is an attempt to implement too many unrelated functions through the Quick Filter bar.

If you toggle the menu selection a second time , then search in this message has the correct behavior.

David can you try to find when this regressed ?
For the record / works properly.
blocking-thunderbird3.2: --- → ?
What do you mean "works properly"?  To actually search in a message via the menu bar, I have to select [Edit >  Find > Find in This Message] TWICE.  In the process, I get the Quick Filter toolbar, which I did not request.  

No, I cannot tell when this bug was introduced.  It was a long time since I previously tried searching for a word within a message.
I think the bug is mischaracterized somewhat (and still exists in Thunderbird 3.1.9 on Linux).  It is not specific to newsgroup messages -- it happens on regular emails too.  If you select Edit > Find > Find in This Message (or, equivalently, CTRL-F) when the Quick Filter bar is NOT already present, and the Find box along the bottom of the window (which searches the current message) is NOT present, Thunderbird opens the Quick Filter bar along the top and searches on all messages INSTEAD of opening the search box along the bottom of the window to search only the current message.

If you select Edit > Find > Find in This Message a second time (when the Quick Filter is already open due to the first attempt), it will correctly open the box along the bottom of the window for searching only the current message.

Also, if you double-click on message to open it in its own tab, and then do Edit > Find > Find in This Message, it will correctly open the search box along the bottom of the window to search only the current message.

In summary, to see the bug you must be in a mail folder (not a single message in its own tab), and the Quick Filter and the search-current-message bars must be closed.
See also bug #564328.
this "should" get resolved by bug 564328.
Status: NEW → RESOLVED
Closed: 11 years ago
OS: Windows XP → All
Resolution: --- → DUPLICATE
Duplicate of bug: 564328
Yes, Edit > Find > Find in This Message shouldn't depend on the account type.
Status: RESOLVED → VERIFIED
blocking-thunderbird3.2: ? → ---
You need to log in before you can comment on or make changes to this bug.