Closed Bug 598965 Opened 9 years ago Closed 9 years ago

Awesome screen can still be panned once the context menu is shown

Categories

(Firefox for Android Graveyard :: General, defect, minor)

defect
Not set
minor

Tracking

(fennec2.0b1+)

VERIFIED FIXED
Tracking Status
fennec 2.0b1+ ---

People

(Reporter: vingtetun, Assigned: vingtetun)

References

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
This is a little regression from the big changes happened into inputhandler this night but still a small bug compare to the diff :)
Attachment #477947 - Flags: review?
Comment on attachment 477947 [details] [diff] [review]
Patch

>+      case "contextmenu":
>+        if (ContextHelper.popupState)
>+          this.cancelPending();
>+        break;

Add a comment in the case block so we know why this code is there, and hopefully it won't be removed without testing for this case. Maybe even point to this bug.
Attachment #477947 - Flags: review? → review+
Vivien - Please land this for beta 1
tracking-fennec: --- → 2.0b1+
Duplicate of this bug: 598961
http://hg.mozilla.org/mobile-browser/rev/5237ea6ffe6d
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
verified FIXED on builds:

Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b6pre) Gecko/20100924 Namoroka/4.0b7pre Fennec/2.0b1pre

and

Mozilla/5.0 (Android; Linux armv71; rv:2.0b6pre) Gecko/20100924 Namoroka/4.0b7pre Fennec/2.0b1pre


There's a follow-up bug here: https://bugzilla.mozilla.org/show_bug.cgi?id=599362
Status: RESOLVED → VERIFIED
bugspam
Assignee: nobody → 21
You need to log in before you can comment on or make changes to this bug.