Specific web page loads 20x slower then netscape 4.75

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
normal
RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: db, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
The page www.aftonbladet.se is using way to much CPU and is like
20x slower then netscape 4.75. Also scrolling is really slow here
while it was smooth on NS4.75. Most (all?) other pages are fast and slick.

And this page is not very big, so it probably should be considered
a bug. Sorry, but I have no other information.
Reporter,

the page loads just fine (much faster than 4.75) for me.  Could you please
provide more information on the build you are using?

Also, please read the bug writing guidelines at
http://www.mozilla.org/quality/bug-writing-guidelines.html

Thanks for using Mozilla and reporting bugs!

Comment 2

18 years ago
Also, please provide CPU info (type and MHz), which could be a factor.

On a p3/500 RH6.2/Gnome box, i can't say i noticed any difference in time, only
in what renders first: Mozilla lays out the text much faster than NC, but
overall download/layout time seems about identical.
If you use a new build, can you test this again?
I suspect it may have been due to some temporary external network hickup.
(Reporter)

Comment 3

18 years ago
I'm using the M18 release packed by readhat (mozilla-M18-4) on a PII-400 RH6.2
Gnome, everything up to date. And it's almost only this page that is slow.

Mozilla says it's Build ID 2000101815. It could be that you use the latest cvs
version of mozilla, and it's already fixed. Sorry for reporting it in that case.

I'm 100% sure that it's not the network connection. I have a fairly fast
connection and I read that site every day. If I load it 10 times with mozilla
and 10 times with NS4.75 it is much, much slower all 10 times on mozilla.

It is something that is different with this page compared to every other page I use.

I could try to get a new build. For the moment I cant build mozilla since I've
change some parts of gcc (but i'll change that back soon anyway). If I can find
a prebuilt version that works and then I'll try it out as fast as possible.

It takes about 1 minute with 100% CPU before the page is finaly loaded. It's
nowhere near that time with ns4.75.

Comment 4

18 years ago
Not seeing this on Windows2000 with latest build (2000110904) on a P1-225 with 
only 80MB RAM:

Loading time NS475: about 25 seconds
Loading time Mozilla: 39 seconds (probably because of swapping on my machine)
(Reporter)

Comment 5

18 years ago
I could also say that I have 256 megs of RAM so there was no swapping. I still
use XFree86 3.3.6 (it's a RH6.2 box). I just loaded the page again and it took
62 seconds. The text is rendered really fast. With ns4.75 it takes maybe 4
seconds to load the page (thats everything, including pictures).

I also noted that after the page is loaded X is using 50% CPU all the time. I
guess that there is something strange with the animated pictures. But I have no
problems with animated pictures on other pages..

So my guess is that there is something with images and XFree86 3.3.6.

Comment 6

18 years ago
Making summary more specific.
Summary: 20x slower then netscape 4.75 → Specific web page loads 20x slower then netscape 4.75

Comment 7

18 years ago
whatever this was, it appears to be fixed. I see no exessive CPU usage there 
with 
the latest build.

If you wish to try a recent build: The very latest is found at 
http://ftp.mozilla.org/pub/mozilla/nightly/latest

There are three different precompiled builds available.
If you have root access and wish to install, you can for instance grab 
mozilla-i686-pc-linux-gnu-sea.tar.gz (Right-click and "save file as")

-uninstall previous installations
-tar -zxvf the tar.gz you downloaded
-cd mozilla-installer
-as root run ./mozilla installer

To initialize registration of installed files, you must start mozilla once as 
root, before as a normal user. Mozilla will actually start immediately after 
installation. (Also run mailnews once if you install that, but no need to create 
a root mail-account. Just quit after mailnews also has started, log out as root, 
and regular users should also be in business.

The slowness you observe while scrolling may be caused by the animated gif's, 
but think you'll find the behaviour to have improved.
If you test a new build, please comment about both download time as well as 
scrolling performance.

Comment 8

18 years ago
This page loads at the same speed or even quicker with Mozilla. Tested on build
(2000110721) on linux.Reporter, please reopen the bug if you still have problems
after installing a current build, and take into account that the page have
tables and can take a little more proccesing that can slow the rendering if you
got a slow proccesor.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

18 years ago
Sorry with status new, make a mistake :-)
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

18 years ago
I downloaded and tried build 2000111221 and it is a little bit faster. Before
over 60 seconds and now 23 seconds. 3x better. But its still 5x slower then
ns4.75 and it is still using 50% CPU on my PII-400 after it have loaded the
page. When I run top, it's X that is using 50% CPU, but it's mozilla that is
causing it.

The old ns4.75 is using almost no CPU after the page have loaded. CPU usage for
X is about 1 percent. This might be a factor that makes the page load slower
also. And the old ns4.75 is also doing the animation. So I have not turned it of
or anything. The pages looks more or less the same. Some small layout
difference, but no error.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 11

18 years ago
I tried some more.

1. Start mozilla (build 2000111221)
2. Go to www.aftonbladet.se (tock 15 seconds this time, someting cached I guess)
3. CPU usage is about 50%.
   I've made a screenshot here
   http://zigo.dhs.org/~dennis/2000_11_13_090651_shot.jpg
4. Klick on one of the articles
5. Klick back to go back to the start page
   Now the CPU usage is low and normal
   http://zigo.dhs.org/~dennis/2000_11_13_090927_shot.jpg

In the screenshots you can see my CPU meter in the gnome-panel. In the first
there are big spikes very periodicly. And in the second shoot there is very
small spikes but with the same frequency. It's just my guess that this have to
do with the animated images, but what else could it be.

Very strange, isn't it..

The DNS i use have been quite bad the last days going up and down, so here is
the links with IP adresses instead. I hope www.granitecanyon.com will fix their
DNS servers soon.

http://194.236.34.191/~dennis/2000_11_13_090651_shot.jpg
http://194.236.34.191/~dennis/2000_11_13_090927_shot.jpg

Please triage.
Assignee: clayton → jst
Status: REOPENED → NEW
(Assignee)

Comment 13

18 years ago
Worksforme, seems reasonably fast, didn't do any comparing but the page shows no
obvious sighns of a problem in mozilla, but then again the site probably changes
daily so who knows...
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.