Closed Bug 599005 Opened 11 years ago Closed 11 years ago

Make personas plus compatible with Thunderbird 3.1

Categories

(Mozilla Labs Graveyard :: Personas Plus, defect)

x86
All
defect
Not set
blocker

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: rdoherty, Assigned: cbeard)

Details

(Whiteboard: [tb31needed])

Attachments

(1 file)

Just tested personas plus with Thunderbird 3.1, definitely doesn't work. Installed, but after restart doesn't show up in the add-on manager.
According to https://addons.mozilla.org/en-US/thunderbird/addon/10900/versions/ version 1.5.3 was declared as compatible with 3.0b4 - 3.1.*, however version 1.6.2 is declared as compatible with 3.0b4 - 3.0.*.

Did amo or someone pick up the wrong versions from the source code? or something?
(In reply to comment #1)
> According to https://addons.mozilla.org/en-US/thunderbird/addon/10900/versions/
> version 1.5.3 was declared as compatible with 3.0b4 - 3.1.*, however version
> 1.6.2 is declared as compatible with 3.0b4 - 3.0.*.

I meant 1.6.1 is declared as compatible with 3.0b4 - 3.0.* (there is no 1.6.2 release currently listed).
Whiteboard: [tb31needs]
This is blocking people using Personas in Thunderbird 3.1, bumping severity to try and get this noticed.

I think there are two fixes needed for this bug:

* Bump the compatible version on amo to 3.1.*
* Bump the install.rdf file max version to 3.1.*, just here: http://hg.mozilla.org/labs/personas/file/a7835722703d/client/client.mk#l66

The AMO one is the important one at the moment.
Severity: normal → blocker
I've given Personas 1.6.1 a run through Thunderbird 3.1.7 and all appears to be working fine. Therefore this is the required version bump so that the next time a personas version is released it'll get the right max version.

All that needs to be done next is for someone to sign into the Mozilla Labs login and edit 1.6.1 and bump the maximum version number to 3.1.*.

I hope you don't mind me pushing this forward, just trying to help it along.
Attachment #498410 - Flags: review?(deb)
I don't really have the technical knowledge required to grant review on anything, but hoping Jorge knows someone who does.  Cc'ing him here.
Attachment #498410 - Flags: review?(jorge)
Comment on attachment 498410 [details] [diff] [review]
[checked in] Bump Max Version for Thunderbird

Reviewed by Kris from the editors team. Quote: "Disabled buttons tend to be a bit hard to read, but other than that everything seems to work as expected."
Attachment #498410 - Flags: review?(jorge) → review+
Comment on attachment 498410 [details] [diff] [review]
[checked in] Bump Max Version for Thunderbird

I've just checked this in: http://hg.mozilla.org/labs/personas/rev/492a6ae3d4a6
Attachment #498410 - Attachment description: Bump Max Version for Thunderbird → [checked in] Bump Max Version for Thunderbird
Attachment #498410 - Flags: review?(deb)
I've raised bug 623986 on the disabled buttons issue.


Who can spend 5 minutes in AMO and just bump the version compatibility for Thunderbird of Personas 1.6.1 to 3.1.* ?

I believe this shouldn't need a new version uploading at this stage.
This should be done by whoever has access to the add-on as an owner or a developer. I've bumped up the compatibility info now, but in the future it's best that this is handled by the devs.

FIXED.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Many thanks.
Status: RESOLVED → VERIFIED
Whiteboard: [tb31needs] → [tb31needed]
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.