Closed Bug 599062 Opened 12 years ago Closed 12 years ago

issuing make does not invalidate fastload/startupcache in opt builds

Categories

(Core :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: Gavin, Assigned: benedict)

References

Details

Attachments

(1 file)

STR:
1) Apply patch to browser/components/sessionstore/src/nsSessionStore.js
2) rebuild obj/browser
3) launch build
4) launch build

After 2), I see:
if test -d ../dist/bin ; then touch ../dist/bin/.purgecaches ; fi
in the console.

After 3), the build is running the unpatched code.
After 4), it's running the patched code.
Okay, so the problem is that we decided to have make invalidation only work in debug builds. It seems that that was probably overzealous, so I'll remove the #ifdef guards around that logic.
Summary: fastload requires two runs to invalidate after rebuilding browser/ → issuing make does not invalidate fastload/startupcache in opt builds
Assignee: nobody → bhsieh
Attachment #478047 - Flags: review?(benjamin)
Attachment #478047 - Flags: approval2.0?
Attachment #478047 - Flags: review?(benjamin)
Attachment #478047 - Flags: review+
Attachment #478047 - Flags: approval2.0?
Attachment #478047 - Flags: approval2.0+
http://hg.mozilla.org/mozilla-central/rev/c11770ffab99
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Depends on: 789346
You need to log in before you can comment on or make changes to this bug.