window.[any object bar] returns undefined. [not any more]

VERIFIED WORKSFORME

Status

()

Core
DOM: Core & HTML
P3
major
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: Prashant Desale, Assigned: joki (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] seems to work now.)

(Reporter)

Description

19 years ago
javascript commands window.locationbar, window.menubar, window.personalbar,
window.scrollbars, window.statusbar, window.toolbar should return "[Object Bar]"
but they return "Undefined"

Product: seamonkey.[ apprunner/Viewer ].
Build: 05-04-08.
OS: Win95, WinNT, Mac OS.

Steps to Reproduce:
1] Please copy code I'm providing.
2] Save as HTML file and open this HTML file in apprunner as well as viewer.
3] This HTML file will show you list of Object Bars. [code uses
window.locationbar, window.menubar, window.personalbar, window.scrollbars,
window.statusbar, window.toolbar]

Expected Results: Each command should return "Object Bar" and it should get
printed on screen as follows.

window.locationbar = [object Bar]
window.menubar = [object Bar]
window.personalbar = [object Bar]
window.scrollbars = [object Bar]
window.statusbar = [object Bar]
window.toolbar = [object Bar]


Actual Results: It shows window.[any object bar]=Undefined as follows.

window.locationbar = undefined
window.menubar = undefined
window.personalbar = undefined
window.scrollbars = undefined
window.statusbar = undefined
window.toolbar = undefined

Code:

<html>
<head>
<title>Test Page</title>
</head>
<body >
<form name="workform">
<SCRIPT LANGUAGE="JavaScript1.1">
document.writeln("<h3>");
document.writeln("Object Bars");
document.writeln("</h3>");
document.writeln("window.locationbar = ");
document.writeln(window.locationbar);
document.writeln("<br>");
document.writeln("window.menubar = ");
document.writeln(window.menubar);
document.writeln("<br>");
document.writeln("window.personalbar = ");
document.writeln(window.personalbar);
document.writeln("<br>");
document.writeln("window.scrollbars = ");
document.writeln(window.scrollbars);
document.writeln("<br>");
document.writeln("window.statusbar = ");
document.writeln(window.statusbar);
document.writeln("<br>");
document.writeln("window.toolbar = ");
document.writeln(window.toolbar);
document.writeln("<br>");
</SCRIPT>
</form>
</body>
</html>


End of Code.

Updated

19 years ago
Whiteboard: [MAKINGTEST] christian@wenz.org

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
Summary: window.[any object bar] returns undefined. [Eg. window.scrollbars] → window.[any object bar] returns undefined. [not any more]
Whiteboard: [MAKINGTEST] christian@wenz.org → [TESTCASE] seems to work now.

Comment 1

19 years ago
works for me on M7 and on Build ID 1999070917; the following is displayed
(Win32/Mac)

Object Bars window.locationbar =  [object BarProp]
window.menubar =  [object BarProp]
window.personalbar =  [object BarProp]
window.scrollbars =  [object BarProp]
window.statusbar =  [object BarProp]
window.toolbar =  [object BarProp]
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

19 years ago
Verified.
You need to log in before you can comment on or make changes to this bug.