Closed Bug 599205 Opened 11 years ago Closed 11 years ago

Controls can show incorrect buffered range after media download finishes

Categories

(Core :: Audio/Video, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 655792

People

(Reporter: kinetik, Unassigned)

Details

I'm not sure where the correct fix for this bug lies, so filing here rather than against the controls for now.

To reproduce:
- Open preload="metadata" video.
- Seek somewhere near the end of the video.  Call this "position X".
- Wait for video to download to the end.
- Seek back to start of video.
- Wait for entire video to be downloaded.

Expected result:
- Controls show entire video is buffered.

Actual result:
- Controls show buffered range that ends just before "position X".

This is caused by the last progress event being dropped due to a previous progress event having fired within the progress event timeout.  I think we special case end-of-download to force a progress event, so we probably need similar handling for when it the end-of-download is not the end-of-file.
Assignee: nobody → fryn
Unassigning myself, since I likely won't be working on this in the near future.
Patches are welcome! :)
Assignee: fryn → nobody
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 655792
You need to log in before you can comment on or make changes to this bug.