Malformed JPEG file leads to crash [@mozilla::imagelib::Decoder::PostFrameStop()]

RESOLVED DUPLICATE of bug 594592

Status

()

Core
ImageLib
--
critical
RESOLVED DUPLICATE of bug 594592
7 years ago
7 years ago

People

(Reporter: posidron, Unassigned)

Tracking

({crash, testcase})

Trunk
x86_64
Mac OS X
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 478173 [details]
testcase

Chunk: None
Number of replaced values: 1
Offset: 2/0x00000002   Value: ['ff','ff','ff', ff']
Diff:
0000000 ff d8 ff ff ff ff 4a
vs.
0000000 ff d8 ff e0 00 10 4a


Load the provided html file.

Last message before crash:

JPEG decoding error:
Unsupported marker type 0x4a
###!!! ABORT: Stopping frame when we didn't start one!: 'mInFrame', file /Users/cdiehl/Mozilla/trunk/modules/libpr0n/src/Decoder.cpp, line 172
(Reporter)

Comment 1

7 years ago
Created attachment 478174 [details]
callstack
I can't reproduce this on a recent nightly - I'm guessing it's a dupe of bug 594592.

Resolving as such - please re-open if you can reproduce this with a recent build.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 594592
(Assignee)

Updated

7 years ago
Crash Signature: [@mozilla::imagelib::Decoder::PostFrameStop()]
You need to log in before you can comment on or make changes to this bug.