Intermittent test_painting.html | partially clipped plugin painted once - got 0, expected 1 and painted after invalidate - got 1, expected 2

RESOLVED DUPLICATE of bug 585286

Status

()

RESOLVED DUPLICATE of bug 585286
8 years ago
8 years ago

People

(Reporter: rstrong, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

+++ This bug was initially created as a clone of Bug #557456 +++

cloning bug 557456 since people are misreporting this orange for the same test in that bug which is for a time out. Perhaps it morphed.

Rev3 Fedora 12x64 mozilla-central opt test mochitests-4/5 on 2010/09/23 22:19:00
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1285305540.1285306125.15212.gz

95639 INFO TEST-PASS | /tests/modules/plugin/test/test_painting.html | zero-sized plugin not painted - 0 should equal 0
NPP_Destroy
95640 INFO TEST-PASS | /tests/modules/plugin/test/test_painting.html | fully clipped plugin not painted - 0 should equal 0
95641 ERROR TEST-UNEXPECTED-FAIL | /tests/modules/plugin/test/test_painting.html | partially clipped plugin painted once - got 0, expected 1
95642 ERROR TEST-UNEXPECTED-FAIL | /tests/modules/plugin/test/test_painting.html | painted after invalidate - got 1, expected 2
95643 INFO SimpleTest finished /tests/modules/plugin/test/test_painting.html in 420ms
95644 INFO TEST-START | /tests/modules/plugin/test/test_pluginstream_asfile.html
from bug 557456 comment #704
> dbaron%dbaron.org
> http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1285128721.1285132117.28021.gz
> Rev3 Fedora 12x64 mozilla-central debug test mochitests-4/5 on 2010/09/21
> 21:12:01
> 
> s: talos-r3-fed64-027
> 11089 ERROR TEST-UNEXPECTED-FAIL |
> /tests/layout/base/tests/test_flush_on_paint.html | Test timed out.
> 38332 ERROR TEST-UNEXPECTED-FAIL |
> /tests/layout/base/tests/test_mozPaintCount.html | Test timed out.
> 132610 ERROR TEST-UNEXPECTED-FAIL |
> /tests/modules/plugin/test/test_painting.html | partially clipped plugin
> painted once - got 0, expected 1
> 132611 ERROR TEST-UNEXPECTED-FAIL |
> /tests/modules/plugin/test/test_painting.html | painted after invalidate - got
> 1, expected 2
> PROCESS-CRASH | Main app process exited normally | application crashed
> (minidump found)
> Thread 0 (crashed)
> PROCESS-CRASH | Main app process exited normally | application crashed
> (minidump found)
> Thread 0 (crashed)
> PROCESS-CRASH | Main app process exited normally | application crashed
> (minidump found)
> Thread 0 (crashed)

from bug 557456 comment #706
> ehsan%mozilla.com
> http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1285195282.1285198723.29289.gz
> Rev3 Fedora 12x64 mozilla-central debug test mochitests-4/5 on 2010/09/22
> 15:41:22
> 
> s: talos-r3-fed64-051
> 10536 ERROR TEST-UNEXPECTED-FAIL |
> /tests/layout/base/tests/test_flush_on_paint.html | Test timed out.
> 37733 ERROR TEST-UNEXPECTED-FAIL |
> /tests/layout/base/tests/test_mozPaintCount.html | Test timed out.
> 132016 ERROR TEST-UNEXPECTED-FAIL |
> /tests/modules/plugin/test/test_painting.html | partially clipped plugin
> painted once - got 0, expected 1
> 132017 ERROR TEST-UNEXPECTED-FAIL |
> /tests/modules/plugin/test/test_painting.html | painted after invalidate - got
> 1, expected 2
> PROCESS-CRASH | Main app process exited normally | application crashed
> (minidump found)
> Thread 0 (crashed)
> PROCESS-CRASH | Main app process exited normally | application crashed
> (minidump found)
> Thread 0 (crashed)
> PROCESS-CRASH | Main app process exited normally | application crashed
> (minidump found)
> Thread 0 (crashed)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Well, at least the failure morph plus morphing the summary here has turned the former "you have to star four timeouts as four separate things even though they occur together" into "you have to star two timeouts plus two failures in just one bug" so I guess that's progress.
Summary: Intermittent test_painting.html | partially clipped plugin painted once - got 0, expected 1 → Intermittent test_painting.html | partially clipped plugin painted once - got 0, expected 1 and painted after invalidate - got 1, expected 2
The morph may have been due to bug 598112, which turned on bug 556487.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 585286
Whiteboard: [orange]
No longer blocks: 438871
You need to log in before you can comment on or make changes to this bug.