Mozilla font size prefs shouldn't affect chrome fonts

VERIFIED FIXED in mozilla0.9

Status

()

Core
CSS Parsing and Computation
P3
minor
VERIFIED FIXED
18 years ago
15 years ago

People

(Reporter: Adrian Havill, Assigned: Pierre Saslawsky)

Tracking

({modern})

Trunk
mozilla0.9
modern
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

18 years ago
Under some Japanese systems (like Red Hat Linux 7J), the text in the mailnews
interface such as "Get Mail" and "Send Mail" is larger than normal because of
the default font used on Japanese systems.

This increases the amount of vertical space that the toolbar takes up, and
produces an unsightly white "blank" area at the bottom of the toolbar because
the theme/skin only fills up a set amount of space based on a Latin-1 font.
(Reporter)

Comment 1

18 years ago
Created attachment 19149 [details]
screenshot showing oversized text

Comment 2

18 years ago
Confirming based on screenshot, but this isn't a UI design issue, it's an 
implementation issue. Over to Themes.

Does this also happen with the Classic theme?
Status: UNCONFIRMED → NEW
Component: User Interface: Design Feedback → Themes
Ever confirmed: true
QA Contact: mpt → pmac
(Reporter)

Comment 3

18 years ago
The font is still large like Modern, but Classic looks ok. (IOW, no "white clip"
with the font decenders for "g" spilling past the skin.

Blue also looks fine.

Comment 4

18 years ago
I also see this. The text size of navigation toolbar seems to obey to
Japanese's variable-width font settings.

My build is 2000112204-Mtrunk on Win98J.
(Reporter)

Comment 5

18 years ago
I also see alignment problems with the larger fonts with mailnews and the "Blue"
theme (look at the drop-down "triangle" under the print button icon... with the
larger text, the triangle is lost in the middle of the "Print" text and looks
like a graphics glitch)
(Reporter)

Comment 6

18 years ago
Created attachment 19778 [details]
shows lost drop-down triangle in middle of ja font "Print" button text
Adding ben + erik so they can ( hopefully ) comment.

Comment 8

18 years ago
Yes, I have heard of many problems with the Modern theme. It hard-codes fonts
(instead of using CSS system fonts), and it hard-codes various UI element sizes
(bad bad).

Comment 9

18 years ago
System font coming soon to Modern.  Sending to Joe to close this bug when system 
fonts supported in Modern.
Assignee: hangas → hewitt

Comment 10

18 years ago
Fixed - see fix for 16729.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
2000122105 on Win98J still has this problem.


Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 12

18 years ago
Koike, I've tested this with very large fonts on windows and don't see the
problem with the extra white space that you describe.  Can you please explain
what you are seeing that looks wrong, and perhaps include a screen shot?
Status: REOPENED → ASSIGNED

Comment 13

18 years ago
I didn't refer to the white space. The problem I still see is the text size
of navigation toolbar changes according to the Japanese's variable-width
font setting. Modern and Blue theme have this problem. Classic theme works
fine. I'll attach the screenshot.


Comment 14

18 years ago
Created attachment 21620 [details]
Screenshot

Comment 15

18 years ago
Koike, perhaps I'm not clear on the way font settings are working on your
system.  In your screen shot it appears one of your system font settings, the
one that corresponds to the CSS2 system font "message-box", is set to a very
large size. Is this because when you read Japanese text you prefer that size,
but in the case of reading English you don't want to adopt that size?

Comment 16

18 years ago
I haven't changed "message-box" settings. The problem is that
the text size of navigation toolbar shoudn't be changed when
the font size is changed with preferences dialog.

Comment 17

18 years ago
Ok, I see the problem now.  Changing summary...
Priority: P3 → P4
Summary: Text under mailnews buttons too big with certain fonts/languages → [Modern] Mozilla font size prefs shouldn't affect chrome fonts

Comment 18

18 years ago
*** Bug 64824 has been marked as a duplicate of this bug. ***

Comment 19

18 years ago
Themes Triage Team nsbeta1+
Keywords: nsbeta1
Priority: P4 → P3

Updated

18 years ago
Target Milestone: --- → mozilla0.9

Updated

17 years ago
Keywords: modern

Updated

17 years ago
Summary: [Modern] Mozilla font size prefs shouldn't affect chrome fonts → Mozilla font size prefs shouldn't affect chrome fonts

Comment 20

17 years ago
I've determined the problem here, and it goes beyond themes.  Whenever the
font-size css property is set to a relative value, like "smaller", the font is
rendered in a value that is relative to the user's font settings.  This is
incorrect, as the value should be relative to the inherited font-size.

Moving this bug over to Style System.
Assignee: hewitt → pierre
Status: ASSIGNED → NEW
Component: Themes → Style System
QA Contact: pmac → ian
hewitt: that does not appear to be true, per this test case:
   http://www.hixie.ch/tests/adhoc/css/fonts/size/001.xml

Reassigning back to Themes. If you still think it is a style system bug, please
attach a test case that shows the problem. Thanks...
Assignee: pierre → hewitt
Component: Style System → Themes
QA Contact: ian → pmac
(Broke bug 72164 out of this bug.)

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 23

17 years ago
Themes Triage Team Marking nsbeta1+
Keywords: nsbeta1 → nsbeta1+

Comment 24

17 years ago
I do still think this is a style system problem.  The test case I'm about to
attach clearly demonstrates the problem.

Assignee: hewitt → pierre
Status: ASSIGNED → NEW
Component: Themes → Style System
QA Contact: pmac → ian

Comment 25

17 years ago
Created attachment 30379 [details] [diff] [review]
test case showing bad font-size: smaller interpretation
(Assignee)

Comment 26

17 years ago
I think the bug happens when |smaller| results in a font size that is smaller 
than the |xx-small| of the font size selected in the prefs.
(Assignee)

Comment 27

17 years ago
I'm going to attach diffs.  When a |smaller| font size results in something 
smaller than the |xx-small| of the base font, we use the parent's font size. Same 
thing for |larger| and |xx-large|.

Marc, could you review?
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 28

17 years ago
Created attachment 31222 [details] [diff] [review]
diffs

Comment 29

17 years ago
The diffs look fine - [s]r=attinasi

Pierre, how did you test this? Did Hewitt's testcase demonstrate the problem and
solution?
(Assignee)

Comment 30

17 years ago
Joe's excellent testcase did show the problem before and not after.  I also 
checked with http://www.w3.org/Style/CSS/Test/current/sec526.htm

Thanks for the review.
(Assignee)

Comment 31

17 years ago
fix checked in nsCSSStyleRule.cpp
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED

Comment 32

15 years ago
verifying based on commetns 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.