Closed Bug 599419 Opened 9 years ago Closed 9 years ago

Text box is panned slightly out of page when selected and typed in

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

All
Android
defect
Not set

Tracking

(fennec2.0b2+)

VERIFIED FIXED
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: mossop, Assigned: mbrubeck)

References

()

Details

Attachments

(3 files)

On the amazon.com mobile site if I tap on the search box it gets panned so it is only half in view. If I pan it into view then it gets moved back out again whenever I press a key.
tracking-fennec: --- → ?
Attached image screenshot
Hardware: ARM → All
Assignee: nobody → wjohnston
Attached patch PatchSplinter Review
We are not observing the max-zoom set by the amazon mobile page. This clamps us to that.
Attachment #479156 - Flags: review?(mbrubeck)
Comment on attachment 479156 [details] [diff] [review]
Patch

>+        Browser.selectedTab.clampZoomLevel(zoomLevel);

This should be:

  zoomLevel = Browser.selectedTab.clampZoomLevel(zoomLevel);
Attachment #479156 - Flags: review?(mbrubeck) → review+
tracking-fennec: ? → 2.0b2+
Duplicate of this bug: 602862
Pushed: http://hg.mozilla.org/mobile-browser/rev/fbccbe691b6a
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
verified FIXED as it's not off the page anymore, but its still not viewable. Follow up bug filed: https://bugzilla.mozilla.org/show_bug.cgi?id=603634

Mozilla/5.0 (Android; Linux armv71; rv:2.0b8pre) Gecko/20101011 Namoroka/4.0b8pre Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
This change was accidentally backed out by http://hg.mozilla.org/mobile-browser/rev/f3c39ab699ec and this bug is occurring again.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Attached patch patch 2Splinter Review
This restore's Wes's fix.  There was also a new problem caused by the way the margin was added to the zoom rect, after it was clamped.  This would cause the new zoom rect not to match the clamped zoom level.  Instead we now apply the margin before clamping the zoom level.

There's still a related problem when focusing the password field on http://touch.facebook.com - the page pans to center the field, then snaps back because Browser.setVisibleRect doesn't know it can scroll the #page-scrollbox when the #content-navigator-spacer is showing.  I'll file a separate bug for that.
Assignee: wjohnston → mbrubeck
Status: REOPENED → ASSIGNED
Attachment #486498 - Flags: review?(wjohnston)
Attachment #486498 - Flags: review?(21)
Comment on attachment 486498 [details] [diff] [review]
patch 2

We were doing like what you do with the margin before but doing my backout they were looking better like that but not a lot. If that messed up something I guess it was a wrong approach.
Attachment #486498 - Flags: review?(21) → review+
New steps to reproduce:
1) Open the login page at http://touch.facebook.com
2) Tap in the username field.

Actual results: Page zooms in slightly, then back out again.
Expected results: Page does not zoom (because zoom is disabled by this page).
Comment on attachment 486498 [details] [diff] [review]
patch 2

Looks good. Thanks matt.
Attachment #486498 - Flags: review?(wjohnston) → review+
Pushed: http://hg.mozilla.org/mobile-browser/rev/9b8cfc698649
Status: ASSIGNED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Filed bug 607824 for the panning problem.
veirfied FIXED on build:
Mozilla/5.0 (Android; Linux armv71; rv:2.0b8pre) Gecko/20101028 Namoroka/4.0b8pre Fennec/4.0b2pre
Setting as verified based on Aakash's statement above
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.