Opensearch suggestsions do not show if the server is slow.

RESOLVED DUPLICATE of bug 533674

Status

()

--
minor
RESOLVED DUPLICATE of bug 533674
8 years ago
8 years ago

People

(Reporter: noitidart, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 (.NET CLR 3.5.30729)

I have a opensearch plugin which features suggestions. But the server is slow. So rather then loading the suggestions after the server finally responds it doesnt show any suggestions at all.
Google chrome had this problem as well but now it works, i type in my word and the server lags so all previous suggestions are cleared and then when the server loads the new suggestions are loaded in.
I dont like how google chrome clears the old search results especially because my search term is still found in the suggestions it cleared. But thats how they fixed it.


The current way to get the new results is to backspace the last letter and wait again.

Thanks!

Reproducible: Always

Steps to Reproduce:
1. Install the addon search plugin. 
2. Function to install the search plugin that has the laggy server:
function installIDBSearchEngine() {
	if (window.external && ("AddSearchProvider" in window.external)) {
		// Firefox 2 and IE 7, OpenSearch
		window.external.AddSearchProvider("http://www.neocodex.us/forum/admin/applications_addon/other/itemdb/cdxidb-opensearch.xml");
	} else if (window.sidebar && ("addSearchEngine" in window.sidebar)) {
		// Firefox <= 1.5, Sherlock
		window.sidebar.addSearchEngine("http://www.neocodex.us/forum/admin/applications_addon/other/itemdb/cdxidb-sherlock.src", "http://www.neocodex.us/forum/favicon.ico", "Neocodex Item Database Search Plugin", "");
	} else {
		// No search engine support (IE 6, Opera, etc).
		alert("ERROR: Your browse does not support custom search plugins");
	}
}
3. Once installed type in slowly one letter at a time any item that is found in the database. For example type in 'codestone ch' without the single quotes.
Actual Results:  
I would get results when the server responded fast. But other times when the server was slow the search terms would disappear and no new suggestions would load even after the server responded. I monitored server response with the addon LiveHTTPHeaders.

Expected Results:  
The suggestions should be loaded in after server responds even if it takes some time.

Ive marked it as minor but i would really like to see it fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 533674
You need to log in before you can comment on or make changes to this bug.