bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

hg -r 54095 brings 32-bit linux X server to its knees. (javascript?)

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: walter sheets, Unassigned)

Tracking

4.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b6pre) Gecko/20100101 Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b6pre) Gecko/20100101 Firefox/4.0b6pre

$hg log -r 54095
changeset:   54095:173e878ad96a
parent:      54094:888afabb303c
parent:      52450:2779c55431a4
user:        Oleg Romashin <romaxa@gmail.com>
date:        Fri Sep 10 22:32:25 2010 -0700
summary:     Merge with mozilla central 2779c55431a4, no conflicts

(Note: this problem affects only 32-bit linux, not 64-bit.)

When viewing npr.org, the X server uses 99% CPU, making the entire machine unusably slow.  Note that firefox is not the process using all the cpu time, rather it's X.

npr.org uses javascript very heavily, so I'm guessing that's where the problem is.

If nobody can reproduce this problem I guess I'll have to learn how to profile javascript :)

Reproducible: Always

Steps to Reproduce:
1.Visit www.npr.org, that's all it takes.
2.
3.

Comment 1

8 years ago
Works for me - Mozilla/5.0 (X11; Linux i686; rv:2.0b7pre) Gecko/20100924 Firefox/4.0b7pre

Loading npr.org both Firefox and X.org are sitting a 0% cpu.
(Reporter)

Comment 2

8 years ago
Interesting.  Just occurred to me that I'm using the nouveau driver for nvidia.  I'll test again with a stable video driver and see if it makes a difference.
(Reporter)

Comment 3

8 years ago
Yup, it's a bug in the nouveau driver after all.  Sorry for the noise.

Updated

7 years ago
Version: unspecified → 4.0 Branch
This bug was reported using a pre-release version of Firefox 4. Now that Firefox 4.0.1 final has been released, can you please update and retest your bug? A fresh profile would be a good starting place to test, 
http://support.mozilla.com/kb/Managing+profiles. If you continue to see the issue, can you please update this bug with your results?

Filter: firefox4prebugsunco
(Reporter)

Comment 5

7 years ago
This bug should be closed as "not a bug", thanks.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.