"Assertion failure: isExtensible(),"

RESOLVED DUPLICATE of bug 599464

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 599464
8 years ago
5 years ago

People

(Reporter: gkw, Assigned: Waldo)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
assertion, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Reporter)

Description

8 years ago
bb = eval
function h() {
  this.eval = bb
}
try {
  (function() {
    Object.defineProperty(this, "eval", ({
      set: Object.preventExtensions
    }));
    l
  })()
} catch(e) {
  h()
}
h()

asserts js debug shell on TM changeset a3ff60f75cb8 without -m nor -j at Assertion failure: isExtensible(),
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?

Updated

8 years ago
blocking2.0: ? → betaN+
(Reporter)

Comment 1

8 years ago
autoBisect shows this is probably related to the following changeset:

The first bad revision is:
changeset:   54276:aa9b86572020
user:        Jim Blandy
date:        Tue Sep 21 11:35:29 2010 -0700
summary:     Bug 492849 - Implement Object.preventExtensions, Object.isExtensible. a=waldo,jimb, r=brendan
Blocks: 492849
(Assignee)

Updated

8 years ago
Assignee: general → jwalden+bmo
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 599464
A testcase for this bug was already added in the original bug (bug 599464).
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.