Configuring TM using ' ./configure --enable-debug --disable-optimize --enable-debugsymbols --disable-tracejit --disable-methodjit' ends in compile errors!

RESOLVED INVALID

Status

()

Core
JavaScript Engine
RESOLVED INVALID
8 years ago
5 years ago

People

(Reporter: ckerschb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: TM: --enable-debug --disable-optimize --enable-debugsymbols --disable-tracejit --disable-methodjit

  

Reproducible: Always

Actual Results:  
../methodjit/MethodJIT.cpp:584:4: error: #error "Unsupported CPU!"
../methodjit/MethodJIT.cpp:126: warning: ‘PushActiveVMFrame’ initialized and declared ‘extern’
../methodjit/MethodJIT.cpp:126: error: variable or field ‘PushActiveVMFrame’ declared void
../methodjit/MethodJIT.cpp:126: error: ‘VMFrame’ was not declared in this scope
../methodjit/MethodJIT.cpp:126: error: ‘f’ was not declared in this scope
../methodjit/MethodJIT.cpp:133: warning: ‘PopActiveVMFrame’ initialized and declared ‘extern’
../methodjit/MethodJIT.cpp:133: error: variable or field ‘PopActiveVMFrame’ declared void
../methodjit/MethodJIT.cpp:133: error: ‘VMFrame’ was not declared in this scope
../methodjit/MethodJIT.cpp:133: error: ‘f’ was not declared in this scope
../methodjit/MethodJIT.cpp:140: warning: ‘SetVMFrameRegs’ initialized and declared ‘extern’
../methodjit/MethodJIT.cpp:140: error: variable or field ‘SetVMFrameRegs’ declared void
../methodjit/MethodJIT.cpp:140: error: ‘VMFrame’ was not declared in this scope
../methodjit/MethodJIT.cpp:140: error: ‘f’ was not declared in this scope
../methodjit/MethodJIT.cpp:179: error: ‘VMFrame’ was not declared in this scope
../methodjit/MethodJIT.cpp:717: error: ‘ThreadData’ has not been declared
../methodjit/MethodJIT.cpp: In function ‘bool Initialize()’:
../methodjit/MethodJIT.cpp:719: error: ‘execPool’ was not declared in this scope
../methodjit/MethodJIT.cpp:723: error: ‘TrampolineCompiler’ was not declared in this scope
../methodjit/MethodJIT.cpp:723: error: expected `;' before ‘tc’
../methodjit/MethodJIT.cpp:724: error: ‘tc’ was not declared in this scope
../methodjit/MethodJIT.cpp:725: error: type ‘<type error>’ argument given to ‘delete’, expected pointer
../methodjit/MethodJIT.cpp:734: error: ‘activeFrame’ was not declared in this scope
../methodjit/MethodJIT.cpp: At global scope:
../methodjit/MethodJIT.cpp:740: error: ‘ThreadData’ has not been declared
../methodjit/MethodJIT.cpp: In function ‘void Finish()’:
../methodjit/MethodJIT.cpp:742: error: ‘TrampolineCompiler’ has not been declared
../methodjit/MethodJIT.cpp:742: error: ‘trampolines’ was not declared in this scope
../methodjit/MethodJIT.cpp:743: error: ‘execPool’ was not declared in this scope
../methodjit/MethodJIT.cpp: At global scope:
../methodjit/MethodJIT.cpp:800: error: ‘JSBool js::mjit::JaegerShot(JSContext*)’ should have been declared inside ‘js::mjit’
../methodjit/MethodJIT.cpp: In function ‘JSBool js::mjit::JaegerShot(JSContext*)’:
../methodjit/MethodJIT.cpp:804: error: ‘struct JSScript’ has no member named ‘ncode’
../methodjit/MethodJIT.cpp:804: error: ‘struct JSScript’ has no member named ‘ncode’
../methodjit/MethodJIT.cpp:804: error: ‘JS_UNJITTABLE_METHOD’ was not declared in this scope
../methodjit/MethodJIT.cpp:813: error: ‘struct JSScript’ has no member named ‘jit’
../methodjit/MethodJIT.cpp: At global scope:
../methodjit/MethodJIT.cpp:817: error: ‘JSBool js::mjit::JaegerShotAtSafePoint(JSContext*, void*)’ should have been declared inside ‘js::mjit’
../methodjit/MethodJIT.cpp:835: error: ‘void js::mjit::ReleaseScriptCode(JSContext*, JSScript*)’ should have been declared inside ‘js::mjit’
../methodjit/MethodJIT.cpp: In function ‘void js::mjit::ReleaseScriptCode(JSContext*, JSScript*)’:
../methodjit/MethodJIT.cpp:837: error: ‘struct JSScript’ has no member named ‘jit’
../methodjit/MethodJIT.cpp:842: error: ‘struct JSScript’ has no member named ‘jit’
../methodjit/MethodJIT.cpp:843: error: ‘struct JSScript’ has no member named ‘jit’
../methodjit/MethodJIT.cpp:846: error: ‘struct JSScript’ has no member named ‘ncode’
../methodjit/MethodJIT.cpp:860: error: ‘struct JSScript’ has no member named ‘jit’
../methodjit/MethodJIT.cpp:865: error: ‘struct JSScript’ has no member named ‘jit’
../methodjit/MethodJIT.cpp: At global scope:
../methodjit/MethodJIT.cpp:870: error: ‘void js::mjit::SweepCallICs(JSContext*)’ should have been declared inside ‘js::mjit’
make[1]: *** [MethodJIT.o] Error 1
make: *** [default] Error 2


Expected Results:  
it should compile without the tracejit and methodjit!
Try a clean build. It works for me.

Comment 2

8 years ago
Maybe you forgot to do autoconf213 in js/src?
Not relevant anymore with the removal of TM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.