If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When trying to enter information into a form, you cannot see the cursor.

VERIFIED DUPLICATE of bug 56853

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED DUPLICATE of bug 56853
17 years ago
17 years ago

People

(Reporter: eyitope, Assigned: rods (gone))

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en] (WinNT; U)
BuildID:    M18

Normally when trying to enter information into a form, the cursor blinks and 
indicates you can start typing.  In Mozilla, you dont see the cursor inside the 
form and you are not aware that you can start typing.  This occured on the 
www.ibm.com page, when trying to peform a search inside the search box (top left 
corner of page).

Reproducible: Always
Steps to Reproduce:
1.Go to www.ibm.com
2.Click inside the search box located on the upper left corner of the page.
3.

Actual Results:  After clicking inside the box, no cursor shows.

Expected Results:  You expect a cursor to blink inside the box, which will 
indicate you can start typing.

Os/2 4.0 Warp; 200Mhz, Build M18

Comment 1

17 years ago
reporter:
I think I can see what you are saying in windows98 but this may not be a bug.

The "text" cursor is there, it is just right up against the left side of the
text input (no left-padding).

There are more problems with the styling of the text input though.  Notice the
quotes around the style colors, etc.  Mozilla does a good job ignoring them,
while IE, of course, renders everything even though it is wrong.

Reporter do you ever see the text cursor while typing?
Or is the problem more because by default, mozilla places the cursor position
right up against the left side of the text input?

Comment 2

17 years ago
This looks like a dupe of an OS/2 only defect we already have:

http://bugzilla.mozilla.org/show_bug.cgi?id=56853

On OS/2, we are drawing entry field borders two big and they are overlaying the 
initial cursor.

*** This bug has been marked as a duplicate of 56853 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.