Intermittent "Problem Loading Page - Server Not Found" only with FireFox 4 beta




8 years ago
8 years ago


(Reporter: Robert Keyes, Unassigned)


Windows 7

Firefox Tracking Flags

(Not tracked)




8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

When selecting a link from bookmarks or a web page, I get an intermittent failure. The request returns the failure "Problem loading page" "Server not found". Failure occurs on about ten percent of the attempts to select a link while the problem is occuring 

What raises my concern is that on the same desktop system, this failure is not seen with either Firefox 3.6.10 or IE8. It only occurs when running Firefox 4.0b6

Reproducible: Sometimes

Steps to Reproduce:
1.Select bookmark at from bookmarks pane
2.Verify that "Problem loading page" did not occur
3.Go back to step 1

Has been happening on and off the past week, since loading Firefox 4 beta.

Seems to occur when there is a slight lag in loading the page, the amount of network delay is such that I would not expect the browser to timeout.  
Actual Results:  
"Problem loading page" error displayed - pressing "Try again" always successfully loads the requests page.

Sample error message below 

Server not found       
Firefox can't find the server at
Check the address for typing errors such as instead of
  If you are unable to load any pages, check your computer's network
  If your computer or network is protected by a firewall or proxy, make sure
    that Firefox is permitted to access the Web.

Expected Results:  
Requested web page should be displayed

Windows 7 x86
Bell Canada ADSL high speed service

McAfee antivirus plus 2010 - realtime scanning, firewall enabled
- McAfee siteadvisor 3.1 installed and disabled (Add-on manager has it flagged "McAfee SiteAdvisor is incompatible with Firefox 4.0.b6
Note - McAfee was installed and working with Firefox 3.6.10, McAfee add-on disabled when Firefox beta 4 installed      

I am willing to collect diagnostics if putting in the effort would be of value - e.g. Wireshark trace of failing request.

Comment 1

8 years ago
The problem is not occurring at the moment, which made me aware that there is one difference in my current Firefox 4 configuration.

For my first week of running Firefox 4 I had the Search Interfaces User Study running. It just completed yesterday. I will monitor to see whether the problem has gone away now that the User Study is no longer active.
Have you checked your firewall and/or proxy (If you have one) and does this happen in a fresh profile?
Version: unspecified → Trunk

Comment 3

8 years ago
I did some further research and found that I am getting DNS Client timeout Windows System events logged - Windows event 1014

Example - "Name resolution for the name timed out after none of the configured DNS servers responded".

I'll confirm whether these timeouts are also occurring with other browsers, e.g. IE8 or Firefox 3. I find it curious that I hadn't noticed web page load errors until I started using the Firefox 4 beta. I'll also check my Windows 7 configuration to identify the trigger for the DNS client timeouts.

Comment 4

8 years ago
My apologies, I was able to recreate this problem under Firefox 3. It appears I have a problem with my configuration that is causing DNS requests to timeout. We can close this problem report.


8 years ago
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.