fennec hangs on page load way too often on Samsung Epic 4G

RESOLVED WORKSFORME

Status

Fennec Graveyard
General
--
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: mevans, Unassigned)

Tracking

Trunk
ARM
Android
Dependency tree / graph

Details

(Reporter)

Description

7 years ago
I recently purchased a Samsung epic 4G. Fennec works for ~5 page loads and then it begins to hang. Eventually the browser hangs completely and a restart is needed. Basically it is unusable as the default browser.
Matt, a couple things might be helpful here:

1. Are there any pages that you see most of the hangs happening on?
2. How many tabs do you have open?
3. Are you using a clean profile?
OS: Mac OS X → Android
Hardware: x86 → ARM
(Reporter)

Comment 2

7 years ago
1. It didn't seem to matter with the page, although I was mostly using www.drudgereport.com and cnn.com I like my news fair and balanced :).

2. mostly just one, but only up to 3.

3. sort of: usually this is a complete reload of the browser. No sync on at this point. So only dirty with use in the current session.
This sounds similar to bug 597093 which was fixed a few days ago.  Do you still see this in the latest nightly build?

Updated

7 years ago
tracking-fennec: --- → 2.0b1+

Comment 4

7 years ago
It is harder to reproduce with chrome methodjit off, but still doable
How are you reproducing?  Install nightly/build build, browse around to a few sites, hang?  To be clear, is this content hanging, or the UI itself?  I got the UI to hang a few days ago, but haven't been able to lately.  Content can seem to hang because of JS bugs, see bug 600304 f.e.

Comment 6

7 years ago
UI I've only seen hang with methodjit on.  Content hangs less frequently, but still seeing it fairly often, but have been unable to get a useful stack on them.
tracking-fennec: 2.0b1+ → 2.0b2+

Comment 7

7 years ago
Are you still seeing these in nightly builds?
(Reporter)

Comment 8

7 years ago
I will try the nightlies tonite.
tracking-fennec: 2.0b2+ → 2.0+
Depends on: 600596
Depends on: 597093
Marking as WFM.
Jit being disabled seems to have made Fennec work on Epic.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.