Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 599824 - [about:support] Improve "Copy all to clipboard" output
: [about:support] Improve "Copy all to clipboard" output
Status: RESOLVED DUPLICATE of bug 518606
Product: Toolkit
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- enhancement with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
Depends on:
  Show dependency treegraph
Reported: 2010-09-27 01:44 PDT by Helder "Lthere" Magalhães
Modified: 2013-05-04 14:07 PDT (History)
3 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Helder "Lthere" Magalhães 2010-09-27 01:44:37 PDT
Currently, about:support "Copy all to clipboard" feature serializes the data displayed in a vertically sparse way, which makes it unfeasible for copy+pasting into bug report comments, emails, etc.

Steps to "reproduce":
1. Go to about:support;
2. Press the "Copy all to clipboard" button;
3. Paste clipboard contents into a simple text editor (for example, Windows Notepad);
4. Paste clipboard into a rich text editor (for example, Microsoft Word).

Expected results:
1. I'd expect the text-only version (from step 3) to be a little more "friendly";
2. I'd expect the rich text version (from step 4) to be a little more "clean".

Proposal is to:
1. Add less indenting in each entry;
2. Combine table cells into information tuples in the form "key: value";
3. Treat the "Profile Directory" entry differently so that either it is suppressed (as there's no value in outputting "Open Containing Folder" in a text output) or actually output the directory as text during export (for example, "Profile Directory: C:\Users\MyUsername\...
4. Remove trailing space currently added all titles ("Application Basics ", etc.) and entries (all of "Application Basics", like "Name ", "Version ", etc.)
5. Maybe also consider expanding/suppressing "Enabled Plugins" and "Build Configuration" in the simple text clipboard version, as links aren't useful in a text-only output (I'm not sure if there's infrastructure for this).

Current output is something like:

  Application Basics



Proposed output would be something like:

  Application Basics
    Name: Firefox
    Version: 4.0b7pre

For an example take a look at bug 594025 comment 30, where I have manually reformatted (part of) the output automatically generated.
Comment 1 skierpage 2012-03-22 16:20:44 PDT
I would also like Copy all to clipboard to output your current profile directory's path (your #3), but that won't be implemented; from bug 658186, "we don't want users accidentally giving away their OS username or profile nonce every time they paste from about:support."
Comment 2 Drew Willcoxon :adw 2013-04-26 14:02:21 PDT
Thanks for the proposal.  There's an older bug about improving the output, so I'm going to dupe this one to that one, but I'll copy your proposal there.

*** This bug has been marked as a duplicate of bug 518606 ***
Comment 3 Helder "Lthere" Magalhães 2013-05-04 14:07:55 PDT
(In reply to Drew Willcoxon :adw from comment #2)
> so I'm going to dupe this one to that one, but I'll copy your proposal there.

Thanks for including my proposal there and not simply marking as duplicate, as many do. ;-)

Note You need to log in before you can comment on or make changes to this bug.