Closed Bug 599830 Opened 10 years ago Closed 10 years ago

Status bar keeps showing "Downloading Message" although Thunderbird entered idle mode

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 565852

People

(Reporter: psm, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100915 Thunderbird/3.1.4

Sometimes a mail is displayed from an IMAP Folder but the Status Bar continues infinitely to show "Downloading Message". This behavior confuses the user using Thunderbird.

Reproducible: Sometimes

Steps to Reproduce:
Difficult, therefore I attached a video showing the problem. Problem also persists in safe-mode.



Investigating with wireshark shows, that Thunderbird goes normal to "IDLE" and sends no more data over the network.
The logfile shows:
2132[3e52880]: 5d20000:mail.server.tld:S-INBOX:SendData: 25 UID fetch 99141 (UID RFC822.SIZE BODY.PEEK[])2132[3e52880]: ReadNextLine [stream=5d2f988 nb=54 needmore=0]
2132[3e52880]: 5d20000:mail.server.tld:S-INBOX:CreateNewLineFromSocket: * 16 FETCH (UID 99141 RFC822.SIZE 3772 BODY[] {3772}2132[3e52880]: 5d20000:mail.server.tld:S-INBOX:STREAM:OPEN Size: 3772: Begin Message Download Stream
[...]
2132[3e52880]: 5d20000:mail.server.tld:S-INBOX:STREAM:CLOSE: Normal Message End Download Stream
2132[3e52880]: ReadNextLine [stream=5d2f988 nb=24 needmore=0]
2132[3e52880]: 5d20000:mail.server.tld:S-INBOX:CreateNewLineFromSocket: 25 OK FETCH completed.2132[3e52880]: 5d20000:mail.server.tld:S-INBOX:SendData: 26 IDLE2132[3e52880]: ReadNextLine [stream=5d2f988 nb=22 needmore=0]
2132[3e52880]: 5d20000:mail.server.tld:S-INBOX:CreateNewLineFromSocket: + entering idle mode
Ofline-use=on? or off?
Same problem as bug 565852? (fixed by trunk only)
(In reply to comment #2)
> Ofline-use=on? or off?
>
Always online mode, IMAP Server in the same building.

> Same problem as bug 565852? (fixed by trunk only)
>
Problem appeared on one-line text/plain messages without any attachments, therefore I'm not sure if it's the same problem.
(In reply to comment #3)
> Always online mode, IMAP Server in the same building.

Question is not for Work Online mode/Work Offline mode.
It's for Folder Properties/Synchronization, offlin use = enabled/disabled.

Simple text/plain of one-line text line? multipart/mixed with text/plain part only?
In my test of bug 565852 with offline-use=off, phenomenon was not observed on simplest/smallest mail(one-line text only), because whole mail data is held in Memory Cache or Disk Cache and multipart on demand(fetch body[1] is always issued upon mail view) is irrelevant to such mail. The simplest/smallest mail was used for stopping infinite "Downloading...".

In your case, fetch body[] is used. It's by auto-sync(offline-use=on), and/or download of non-multipart mail with offline-use=off.
> 25 UID fetch 99141 (UID RFC822.SIZE BODY.PEEK[])
As size=3772, the mail is small one. Probably simple text/plain mail.

Does "Downloading ..." never disappear in your case? When(by what operation) does the "Downloading ..." disappear?
What I forgot to mention earlier: the problem happens mostly on IMAP accounts that are shared among different persons (5-10 persons are logged in with the same account and password)

(In reply to comment #4)
> Question is not for Work Online mode/Work Offline mode.
> It's for Folder Properties/Synchronization, offlin use = enabled/disabled.

It's disabled ("Select this folder for offline use" is not selected)

> Simple text/plain of one-line text line? multipart/mixed with text/plain part
> only?

text/plain only. I attached another logfile from today where you can see the structure of the e-mail.

> Does "Downloading ..." never disappear in your case? When(by what operation)
> does the "Downloading ..." disappear?

It disappears when I select another message to display. But when I change back to the one that produces the error, the "Downloading ..." message appears again.
It happens only if the message is one of the two newest in the inbox, it never happens to the third mail or the other older mails.

I could reproduce the issue with the latest nightly build:
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.2/thunderbird-3.1.5pre.en-US.win32.zip
(In reply to comment #5)
> But when I change back to the one that produces the error, the "Downloading ..." message appears again.

Simple text/plain(or HTML) message? Or multipart message?
If multipart/xxx message, I can't guess other than phenomenon of bug 565852, because your case is also offline-use=off.

> I could reproduce the issue with the latest nightly build:
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.2/thunderbird-3.1.5pre.en-US.win32.zip

latest-comm-1.9.2 is for next Tb 3.1.x. Fix of bug 565852 is not applied.
Check with ZIP build at next directory for trunk builds, please. 
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/
(In reply to comment #7)
> > But when I change back to the one that produces the error, the "Downloading ..." message appears again.
> 
> Simple text/plain(or HTML) message? Or multipart message?
> If multipart/xxx message, I can't guess other than phenomenon of bug 565852,
> because your case is also offline-use=off.

Both of them. In the logfile it was a multipart message, but I had also the situation with text/plain

> latest-comm-1.9.2 is for next Tb 3.1.x. Fix of bug 565852 is not applied.

Ok. With todays nightly from 3.3a1 I could not reproduce the issue. So it could be the same issue as bug 565852.
Somehow it's not very easy to find out in which version a bug marked as resolved was fixed.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 565852
You need to log in before you can comment on or make changes to this bug.