Sort of emails sorts on quotation mark, [ " ]. All emails to "John" are sorted above all emails to John (ie without the optional quotation marks)

RESOLVED DUPLICATE of bug 273884

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 273884
7 years ago
3 years ago

People

(Reporter: John_Ha, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.9) Gecko/20100915 Thunderbird/3.1.4

When Thunderbird displays the recipient's name in a folder view of emails, the name sometimes has quotation marks [a quotation mark is "], and appears as "John", and sometimes does not have quotation marks, and appears as John.  I believe this may be because some email clients add quotation marks to names whereas some email clients do not. 

The problem arises when I click on the RECIPIENT title in the folder title bar to sort the emails by Recipient's name.  All those emails displayed with quotation marks are sorted together, and all those without quotation marks are sorted together.  Consequently, two emails with the same recipient are widely separated in the sort order, depending on whether they have quotation marks or do not have quotation marks.  

Reproducible: Always

Steps to Reproduce:
1. Click on a folder with many emails 
2. Ensure that RECIPIENT is included as a column  
3. Click on the RECIPIENT column title bar so as to sort the emails according to the Recipient's name.

All emails where the Recipient's name has quotation marks, as "John" are sorted together; and all emails where the Recipient's name does not have quotation markls, as John, are sorted separately.  


Actual Results:  
Assume I have 1000 emails, some with quotation marks and some without.  The emails are sorted as follows: 

email 1   "aaa"
email 2   "bbb"
...
email 500 "zzz"
email 501 aaa
email 502 bbb
...
email 1000 zzz

This makes it difficult to find emails to a given recipient - it depends on whether the name has quotation marks or not.  Two emails which have the same recipient aaa and "aaa" are 500 emails apart in the sort order.

Expected Results:  
All emails with the same Recipient should appear together in the sort order.

Thunderbird (Windows?) should ignore the quotation marks when sorting just as it ignores Upper/Lower case differences.
(Reporter)

Updated

7 years ago
Summary: Sort of emails sorts on " so all emails to "John" are sorted above email to John (ie without the optional quotation marks) → Sort of emails sorts on quotation mark, [ " ]. All emails to "John" are sorted above all emails to John (ie without the optional quotation marks)

Comment 1

3 years ago
Thomas, have you see other reports like this?
Flags: needinfo?(bugzilla2007)

Comment 2

3 years ago
(In reply to Wayne Mery (:wsmwk) from comment #1)
> Thomas, have you see other reports like this?

Of course, I know all them bugs ;)

https://bugzilla.mozilla.org/buglist.cgi?quicksearch=%3Athun%2Cmailn%20sort%20quot&list_id=11951770
Seamonkey bug 163794 (probably fixed, too), points to
Thunderbird bug 273884 (fixed by bug 842632)

Which makes this a dupe.
Quick test with...
msg1: To: foo <...> 
msg2: To: "foo" <...>
...shows that quotation marks are eliminated from the column display and thus indeed no longer disturbing the sorting.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(bugzilla2007)
Resolution: --- → DUPLICATE
Duplicate of bug: 273884
You need to log in before you can comment on or make changes to this bug.