Inserting an image in Joomla 1.0.15 FF 3.6.09+ seems to remove the src tag

RESOLVED DUPLICATE of bug 596513

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 596513
7 years ago
7 years ago

People

(Reporter: dean.beedell.lightquick.co.uk, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 (.NET CLR 3.5.30729)

Inserting an image in Joomla 1.0.15 FF 3.6.09+ using the JCE editor or other tool has always worked for many years. Recent changes to FF, could be from 3.6.09 onwards seems to remove the src tag from the inserted code. However, when you perform the same function a second time it does the insert correctly.

This is what it inserts first time:
<img alt="300_simon_williams.jpg" title="300_simon_williams.jpg" style="float: left; margin: 5px; width: 212px; height: 273px" width="212" height="273" />


This is what it should insert:
<img src="http://domainname.co.uk/images/stories/300_simon_williams.jpg" alt="300_simon_williams.jpg" title="300_simon_williams.jpg" style="float: left; margin: 5px; width: 212px; height: 273px" width="212" height="273" />

This is what it inserts if the function is used a second time:
<img src="http://domainname.co.uk/images/stories/300_simon_williams.jpg" alt="300_simon_williams.jpg" title="300_simon_williams.jpg" style="float: left; margin: 5px; width: 212px; height: 273px" width="212" height="273" />

It occurs on all my sites, these are stable Joomla 1.0.15 sites that have not been upgraded for years, they are on different servers. It happens to all of them.

Reproducible: Always

Steps to Reproduce:
1.Log on to front end of site using priv/unpriv user/pass
2.write new article
3.insert image
Actual Results:  
shows a boundary box of the correct size with no image within

Expected Results:  
should display an image on the page

the problem is not manifested in IE nor Opera
(Reporter)

Updated

7 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Comment 1

7 years ago
Although Joomla 1.0 is superceded by Joomla 1.5 and J1.0.15 is "no-longer supported or maintained and thus cannot be guaranteed to be compatible with later standards or browser capabilities" it forms the basis for 1,000s of existing sites. It also forms the basis of the new Joostina CMS and I can confirm that the bug affects all those sites too.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 596513
You need to log in before you can comment on or make changes to this bug.