Closed Bug 599873 Opened 14 years ago Closed 14 years ago

Cannot do a two-finger page down gesture on about:license

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

ARM
Android
defect
Not set
normal

Tracking

(fennec2.0b2+)

VERIFIED FIXED
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: aakashd, Assigned: wesj)

References

Details

Attachments

(2 files, 2 obsolete files)

Build Id:
Mozilla/5.0 (Android; Linux armv71; rv:2.0b6pre) Gecko/20100927 Namoroka/4.0b7pre Fennec/2.0b1pre

Steps to Reproduce:
1. Go to about:license
2. Try to pan 1/4 of the way down
3. Do a two-finger gesture up to go to the bottom of the page

Actual Results:
The two-finger gesture "up" to go to the bottom of the page moves the position of the page to the top of the page

Expected Results:
The two-finger gesture "up" should go to the bottom of the page. This works fine on planet.mozilla.org
tracking-fennec: --- → ?
These values need to be clamped. Also adds cheat codes.
Assignee: nobody → wjohnston
Attachment #478795 - Flags: review?(mbrubeck)
Comment on attachment 478795 [details] [diff] [review]
Clamp scroll values for non-remote

>+++ b/chrome/content/browser.js
>@@ -103,17 +103,36 @@ function onDebugKeyPress(ev) {
>   const t = 84;
>   const u = 85;
>   const v = 86;
>   const w = 87;
>   const x = 88;
>   const y = 89;
>   const z = 90;

Looks good! Please add comments here for the new cheat codes.
Attachment #478795 - Flags: review?(mbrubeck) → review+
Whiteboard: [fennec-checkin-postb1]
tracking-fennec: ? → 2.0b2+
pushed:
http://hg.mozilla.org/mobile-browser/rev/1bff12cbd051
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Whiteboard: [fennec-checkin-postb1]
Depends on: 600825
This patch regressed bug 599220. I am backing it out.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached patch Fix v2Splinter Review
Forgot to shift the scrollBy values back. Sorry.
Attachment #478795 - Attachment is obsolete: true
Attachment #479803 - Flags: review?(mark.finkle)
Comment on attachment 479803 [details] [diff] [review]
Fix v2

Works now - Thanks
Attachment #479803 - Flags: review?(mark.finkle) → review+
pushed:
http://hg.mozilla.org/mobile-browser/rev/dc74b10bed8c
Status: REOPENED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → FIXED
verified : 
Mozilla/5.0 (Android; Linux armv71; rv2.0b7pre) Gecko/20101001 Firefox/4.0b7pre Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
Attached patch Tests for scrolling and gestures (obsolete) — Splinter Review
Here are some basic tests for gestures in local and remote pages, as well as scrolling in both. (Hope I did this right...)
Attachment #480271 - Flags: review?(mbrubeck)
Flags: in-testsuite?
Comment on attachment 480271 [details] [diff] [review]
Tests for scrolling and gestures

>+  browser_scroll.js \

I think this file is missing from the patch.

The gesture test looks perfect!
Attached patch TestsSplinter Review
Now with all the files. Not sure if these scrolling tests are already covered in the panning gestures stuff anyway, but figure these should have caught my error in the first patch.
Attachment #480271 - Attachment is obsolete: true
Attachment #481000 - Flags: review?(mbrubeck)
Attachment #480271 - Flags: review?(mbrubeck)
Depends on: 602039
Comment on attachment 481000 [details] [diff] [review]
Tests

>+    waitForAndContinue(gCurrentTest.onPageReady2, pageLoaded(remoteUrl));

If you use waitForAndContinue here, you should add a check for "is(pageLoaded(remoteUrl));" to the top of onPageReady2.

You might also want to use waitForAndContinue for the local page test, and add a similar check.

(Also I think there is a bug in waitForAndContinue; filed as bug 602039.)

Looks good; we can fix the nit on checkin.
Attachment #481000 - Flags: review?(mbrubeck) → review+
Comment on attachment 481000 [details] [diff] [review]
Tests

Hmm, running these tests locally on desktop I get some failures:

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/mobile/chrome/browser_gesture.js | Swipe up pans to bottom - Got 412, expected 500
TEST-PASS | chrome://mochitests/content/browser/mobile/chrome/browser_gesture.js | Swipe down pans to top
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/mobile/chrome/browser_gesture.js | Swipe up pans to bottom - Got 320, expected 300


TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | Can't scroll past bottom - Got 412, expected 520
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | Can scroll up - Got 362, expected 470
TEST-PASS | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | Can't scroll past top
TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | testing scrollto in vertical directions
TEST-PASS | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | Can scroll down
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | Can't scroll past bottom - Got 412, expected 520
TEST-PASS | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | Can scroll up
TEST-PASS | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | Can't scroll past top
TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | testing scrollby in horizontal directions
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | Can scroll right - Got 20, expected 100
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | Can't scroll past right - Got 20, expected 200
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | Can scroll left - Got 0, expected 150
TEST-PASS | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | Can't scroll past left
TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | testing scrollto in horizontal directions
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | Can scroll right - Got 20, expected 100
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | Can't scroll past right - Got 20, expected 200
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/mobile/chrome/browser_scroll.js | Can scroll left - Got 20, expected 200
Attachment #481000 - Flags: review+
Dang it. I worked through all of those till I was getting no failures here. You don't have any funny prefs do you? Default sizes or zooming? I tried to be independent of that stuff, but I took the easy route a few places in the gestures tests ... I'll keep digging.
(In reply to comment #15)
> Dang it. I worked through all of those till I was getting no failures here. You
> don't have any funny prefs do you? Default sizes or zooming?

No, and the test harness should start up with a fresh profile.

Maybe a previous test is leaving the browser in an odd state?  Also, can you make sure the attached patch is up to date with what you have locally?
I didn't realize that I shouldn't(?) have browser_bug593387.js running here. I was able to reproduce these errors by disabling it, and then fixed them by updating to the decks patch (i.e. I think they are due to scaling problems).

There is an occasional failure in the "Swipe up pans to bottom".
(In reply to comment #17)
> I didn't realize that I shouldn't(?) have browser_bug593387.js running here. I
> was able to reproduce these errors by disabling it, and then fixed them by
> updating to the decks patch (i.e. I think they are due to scaling problems).

I'm still seeing the same errors running the tests from attachment 481000 [details] [diff] [review] in mobile-browser tip (including the <deck> patch).  I'll take a closer look and try to figure out why.
You need to log in before you can comment on or make changes to this bug.