Firefox hangs on Rescuetime.com dashboard

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: jara.karel, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100927 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100927 Firefox/4.0b7pre

When you go to http://rescuetime.com/dashboard, Firefox hangs and the process must be killed and Firefox started again in order to continue using it.

Reproducible: Always

Steps to Reproduce:
1. Go to http://rescuetime.com/dashboard. (Must have account.)
Actual Results:  
Firefox hangs.

Expected Results:  
Firefox should continue working as usual.

Updated

8 years ago
Version: unspecified → Trunk

Comment 1

8 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100927 Firefox/4.0b7pre

Able to reproduce the bug. As soon as i log into the dashboard, Firefox hangs. Need to force quit firefox. Works fine in firefox 4.0 Beta 6.
Error : Exception :  Tip is not defined Source File: https://www.rescuetime.com/dashboard Line: 527, Column: 0, Category: content javascript.

Comment 2

8 years ago
Also able to see this error in Error Console in Firefox beta 6. 
Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIFile.remove]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://testpilot/modules/lib/securable-module.js -> resource://testpilot/modules/jar-code-store.js :: anonymous :: line 167"  data: no]
Source File: resource://testpilot/modules/lib/securable-module.js -> resource://testpilot/modules/jar-code-store.js
Line: 167

Updated

8 years ago
Component: General → Test Pilot
Product: Firefox → Mozilla Labs
QA Contact: general → test-pilot
Target Milestone: --- → --
I would like to nominate this to block, but this product/component doesn't give me that option.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

8 years ago
Well, actually I don’t think I have Test Pilot installed. So what does this have to do with Test Pilot? Is it integrated in Firefox 4.0b7pre?
Why is this in the Test Pilot component?
I placed it Test Pilot because of comment #2.
Pretty sure that's a red herring. Moving to JS.

Reporter: can you provide an account for us to use for testing?
Assignee: nobody → general
Component: Test Pilot → JavaScript Engine
Product: Mozilla Labs → Core
QA Contact: test-pilot → general
Target Milestone: -- → ---
blocking2.0: --- → ?
(Reporter)

Comment 8

8 years ago
No, I can’t provide my account for testing because there is quite a lot of personal information there.

Comment 9

8 years ago
I think this is fixed.
Status: NEW → RESOLVED
blocking2.0: ? → betaN+
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.