Clear recent history doesnt clean recently closed tabs 1st time

RESOLVED WORKSFORME

Status

()

Firefox
Private Browsing
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: pn_walker, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100927 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100927 Firefox/4.0b7pre

Clear recent history doesn't clean recently closed tabs 1st time.  You have to clear recent history a second time for the recently closed tabs to actually clear

Reproducible: Always
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk

Updated

8 years ago
Component: Bookmarks & History → Private Browsing
QA Contact: bookmarks → private.browsing

Comment 1

8 years ago
Can you please try this in a clean profile, and include steps to reproduce the problem in the bug?

Comment 2

8 years ago
Works for me.

Comment 3

8 years ago
Component should be Bookmarks & History, and Paul, could you tell us what build you were using Ex. Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b8pre) Gecko/20101203 Firefox/4.0b8pre ID:20101203044708
(In reply to comment #3)
> Component should be Bookmarks & History

Nope, it should be either Private Browsing (CRH dialog is usually managed here) or Session Restore (since it's about recent closed tabs)

Comment 5

8 years ago
(In reply to comment #3)
> Component should be Bookmarks & History, and Paul, could you tell us what build
> you were using Ex. Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b8pre)
> Gecko/20101203 Firefox/4.0b8pre ID:20101203044708

I was using the trunk of the day at the time Win7 x86.

Comment 6

8 years ago
WFM
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101221 Firefox/4.0b9pre

Comment 7

8 years ago
I tried to clear the history with and without private browsing.
I dont see problem in both cases. In private browsing you cant clear the history, maybe because its not stored permanently and after you end the session your private browsing history is deleted automatically.

Comment 8

8 years ago
-> WFM.

Original reporter:  please reopen if you can provide more information on how to reproduce this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.