Safe Mode dialog option to Disable all add-ons non-functional

VERIFIED FIXED in mozilla2.0b7

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: rjohnson19, Assigned: mossop)

Tracking

Trunk
mozilla2.0b7
x86
Windows 7
Points:
---
Bug Flags:
in-testsuite -
in-litmus +

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100927 Firefox/4.0b7pre

Steps to Reproduce:
1. Open a profile with at least one enabled add-on installed.
2. Use either the menu item or the command line option to restart into Safe Mode and bring up the safe mode dialog.
3. Check the option to Disable all add-ons and press Make changes and restart
4. Open the Add-ons Manager

Actual Results:
The add-on(s) are still enabled.

Expected Results:
All add-ons should be disabled.
(Reporter)

Comment 1

8 years ago
In a clean profile, attempting to use this method on a single installed extension results in the addons manager indicating that the extension will be disabled on the next restart.

But after several restarts it remains in the same state.

Enabling it and restarting, then disabling it manually works as expected.

On my main profile, which has 6 extensions, 3 unpacked and 3 in XPIs, the dialog option has no effect.
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
(Assignee)

Updated

8 years ago
blocking2.0: --- → ?
While I can see the same on Windows, recent builds on OS X don't show this behavior.
(Assignee)

Comment 3

8 years ago
This probably reproduces randomly as there is a race condition. The code to disable all add-ons starts an asynchronous request to get the list of add-ons and then tells the application to restart. If that async request returns after the app has gotten too far along shutting down then it is unable to make any changes.

The application should be shutdown after the async request completes, probably the window should be kept alive until then too.
Blocks: 575157
blocking2.0: ? → betaN+
Duplicate of this bug: 602524
(Assignee)

Comment 5

8 years ago
Created attachment 481592 [details] [diff] [review]
patch rev 1

This stops the restart button from closing the window and just lets the restart take care of that. It makes the restart happen from the async callback instead when that box is ticked.
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #481592 - Flags: review?(gavin.sharp)
(Assignee)

Updated

8 years ago
Whiteboard: [has patch][needs review gavin]
Attachment #481592 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 6

8 years ago
Fixed: http://hg.mozilla.org/mozilla-central/rev/1f487e14b701
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite-
Flags: in-litmus?
Resolution: --- → FIXED
Whiteboard: [has patch][needs review gavin]
Target Milestone: --- → mozilla2.0b8
Verified fixed with Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101023 Firefox/4.0b8pre
Status: RESOLVED → VERIFIED

Updated

8 years ago
Target Milestone: mozilla2.0b8 → mozilla2.0b7
Flags: in-litmus? → in-litmus?(vlad.maniac)
Litmus test has been added:
https://litmus.mozilla.org/show_test.cgi?id=15171
Flags: in-litmus?(vlad.maniac) → in-litmus+
You need to log in before you can comment on or make changes to this bug.