dst-offset-caching-8-of-8.js: assertion count 3 is more than expected 0 assertions

VERIFIED DUPLICATE of bug 594666

Status

()

Core
JavaScript Engine
VERIFIED DUPLICATE of bug 594666
7 years ago
7 years ago

People

(Reporter: sgreenlay, Unassigned)

Tracking

({assertion})

Trunk
x86
Mac OS X
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1285624599.1285627797.11749.gz

s: win32-slave40
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-jsreftest/build/jsreftest/tests/jsreftest.html?test=ecma/Date/dst-offset-caching-8-of-8.js | assertion count 3 is more than expected 0 assertions

Build Error Log

 Skipping 55017 Lines...

xul!XRE_AddJarManifestLocation+0x0000000000014911
xul!XRE_AddJarManifestLocation+0x0000000000010D5A
xul!gfxFontStyle::Equals+0x0000000000528DF3
xul!gfxFontStyle::Equals+0x000000000038D02D
xul!ShutdownHooker+0x00000000000071A6
xul!ShutdownHooker+0x00000000000070E2
xul!ShutdownHooker+0x0000000000006FC3
xul!mozilla::layers::LayerManagerOGL::operator=+0x000000000004BEC0
xul!DumpJSValue+0x0000000000243542
xul!DumpJSValue+0x00000000001B40FA
xul!gfxFontStyle::Equals+0x00000000000202F6
0x0000000000402532
0x0000000000401CCE
0x00000000004075B6
0x000000000040740D
kernel32!ProcessIdToSessionId+0x0000000000000209

*** Potential deadlock between Lock@526ecd0 and Lock@5c2fdb0

Current stack:
stacks_disabled+0[stacks_disabled +0x0]

Previous stack:
stacks_disabled+0[stacks_disabled +0x0]

###!!! ASSERTION: Potential deadlock between Lock@526ecd0 and Lock@5c2fdb0: 'Error', file e:/builds/moz2_slave/mozilla-central-win32-debug/build/obj-firefox/xpcom/build/nsAutoLock.cpp, line 318
--DOMWINDOW == 7 (05967470) [serial = 971] [outer = 03C66068] [url = file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-jsreftest/build/jsreftest/tests/jsreftest.html?test=ecma/Date/dst-offset-caching-7-of-8.js]
REFTEST TEST-PASS | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-jsreftest/build/jsreftest/tests/jsreftest.html?test=ecma/Date/dst-offset-caching-8-of-8.js |   item 1
REFTEST INFO | Loading a blank page
++DOMWINDOW == 8 (04E18E30) [serial = 974] [outer = 03C66068]
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-jsreftest/build/jsreftest/tests/jsreftest.html?test=ecma/Date/dst-offset-caching-8-of-8.js | assertion count 3 is more than expected 0 assertions
REFTEST TEST-START | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-jsreftest/build/jsreftest/tests/jsreftest.html?test=ecma/ExecutionContexts/10.1.3-1.js
++DOMWINDOW == 9 (05899BC8) [serial = 975] [outer = 03C66068]
(Reporter)

Updated

7 years ago
Whiteboard: [orange]

Updated

7 years ago
Blocks: 438871

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 594666
V.Duplicate
No longer blocks: 438871
Status: RESOLVED → VERIFIED
Keywords: assertion
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.