last page visited should allow for chrome: or about: local pages

VERIFIED FIXED in 2.0

Status

Input
General
P2
normal
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: nhirata, Assigned: wenzel)

Tracking

Details

Mozilla/5.0 (Maemo;Linux armv71; rv:2.0b7pre)Gecko/20100927 Firefox/4.0b7pre Fennec/2.0b1pre

Mozilla/5.0 (Android; Linux armv71; rv2.0b7pre) Gecko/20100927 Firefox/4.0b7pre Fennec/2.0b1pre

1. goto about:firstrun
2. go to the control panel
3. select the beta icon
4. select happy face
5. type in the text
6. select the add URL of last visited page checkbox
7. click the submit Feedback button

Expected: webpage would submit
Actual: Enter a valid URL.

Note:
1. suggestion to add local pages if the user wants to submit feedback on the about: or the chrome: pages.
Did not mean to include android.  Meant Mac Os X:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20100927 Firefox/4.0b7pre Fennec/2.0b1pre
Component: General → Input
Product: Fennec → Webtools
QA Contact: general → input
Target Milestone: --- → 1.8
Version: Trunk → 1.7
I'll look into this and see if it really is an Input bug. There might be an issue around the function call in MobiFx's feedback add-on to POST the URL to our submission pages.
(Assignee)

Comment 3

7 years ago
Yea, Input uses a Django URLfield for this, which checks for valid HTTP(S) URLs. So about:blank and friends are not currently accepted.
Target Milestone: 1.8 → 2.0
Summary: Web content should allow last page visited to allow for chrome: or about: local pages. → [Feedback]Web content should allow last page visited to allow for chrome: or about: local pages.
Summary: [Feedback]Web content should allow last page visited to allow for chrome: or about: local pages. → last page visited should allow for chrome: or about: local pages
We should accept anything starting with "about:" as there are a number of pages that users will see with firefox 4 (i.e. about:addons) that will be related to bugs.
Priority: -- → P2
Duplicate of this bug: 604250
(Assignee)

Updated

7 years ago
Assignee: nobody → fwenzel
(Assignee)

Comment 6

7 years ago
I had to mess with the URL validator to get about: and chrome:// URLs to be accepted as well.

http://github.com/fwenzel/reporter/commit/7ff5c90

This contains multiple unit tests, both for the validator accepting such URLs as well as the view itself accepting the submission.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Verified FIXED:

http://input.stage.mozilla.com/en-US/opinion/637601 (chrome: URL)
http://input.stage.mozilla.com/en-US/opinion/637599 (about: URL)

In-litmus- because this has unit tests (thanks, Fred!!)
Status: RESOLVED → VERIFIED
Flags: in-litmus-
Component: Input → General
Product: Webtools → Input
You need to log in before you can comment on or make changes to this bug.