[D3D9] Start-up crash [@ CD3DBase::Init() ]

RESOLVED WONTFIX

Status

()

Core
Graphics
RESOLVED WONTFIX
7 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Assigned: bjacob)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(crash signature)

(Reporter)

Description

7 years ago
Build : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100927
Firefox/4.0b7pre

This is a new crash signature that is introduced by this build.
Until now, it happens only on start-up under Windows 7.

Signature	CD3DBase::Init()
UUID	0cbb13d6-e2ed-40da-bfb3-189cc2100927
Time 	2010-09-27 20:00:43.155526
Uptime	4
Last Crash	7 seconds before submission
Install Age	8 seconds since version was first installed.
Product	Firefox
Version	4.0b7pre
Build ID	20100927041306
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 11
Crash Reason	EXCEPTION_ACCESS_VIOLATION_EXEC
Crash Address	0xffffffffba7d8254
App Notes 	AdapterVendorID: 1002, AdapterDeviceID: 71c7

Frame 	Module 	Signature [Expand] 	Source
0 		@0xba7d8254 	
1 	d3d9.dll 	CD3DBase::Init 	
2 	d3d9.dll 	CEnum::CreateDeviceImpl 	
3 	d3d9.dll 	CEnum::CreateDeviceEx 	
4 	xul.dll 	mozilla::layers::DeviceManagerD3D9::Init 	
5 	xul.dll 	mozilla::layers::LayerManagerD3D9::Initialize 	gfx/layers/d3d9/LayerManagerD3D9.cpp:95
6 	xul.dll 	nsWindow::GetLayerManager 	widget/src/windows/nsWindow.cpp:3222
7 	xul.dll 	PresShell::DocumentStatesChanged 	layout/base/nsPresShell.cpp:5011
8 	xul.dll 	nsDocument::DocumentStatesChanged 	content/base/src/nsDocument.cpp:4329
9 	xul.dll 	NotifyDocumentTree 	dom/base/nsGlobalWindow.cpp:7147
10 	xul.dll 	nsGlobalWindow::SetActive 	dom/base/nsGlobalWindow.cpp:7155
11 	xul.dll 	nsGlobalWindow::ActivateOrDeactivate 	dom/base/nsGlobalWindow.cpp:7139
12 	xul.dll 	nsFocusManager::WindowRaised 	dom/base/nsFocusManager.cpp:669
13 	xul.dll 	nsWebShellWindow::HandleEvent 	xpfe/appshell/src/nsWebShellWindow.cpp:447
14 	xul.dll 	nsWindow::DispatchEvent 	widget/src/windows/nsWindow.cpp:3532
15 	xul.dll 	nsWindow::DispatchWindowEvent 	widget/src/windows/nsWindow.cpp:3562
16 	xul.dll 	nsWindow::DispatchFocus 	widget/src/windows/nsWindow.cpp:4085
17 	xul.dll 	nsWindow::DispatchFocusToTopLevelWindow 	widget/src/windows/nsWindow.cpp:4048
18 	xul.dll 	nsWindow::ProcessMessage 	widget/src/windows/nsWindow.cpp:5107
19 	xul.dll 	nsWindow::WindowProcInternal 	widget/src/windows/nsWindow.cpp:4338
20 	xul.dll 	nsWindow::WindowProc 	widget/src/windows/nsWindow.cpp:4290
...

More reports at :
http://crash-stats.mozilla.com/report/list?product=Firefox&version=Firefox%3A4.0b7pre&query_search=signature&query_type=exact&query=CD3DBase%3A%3AInit%28%29&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=CD3DBase%3A%3AInit%28%29
blocking2.0: --- → ?
This could be related to the fixing of bug 594976. Perhaps those device are just thoroughly messed up and shouldn't be getting HW accel at all?
Depends on: 594976
(Reporter)

Comment 2

7 years ago
> This could be related to the fixing of bug 594976.
Except that bug 594976 landing is in b7pre/20100928 build and not in b7pre/20100927.
That's interesting... since nothing touched this code since then :s.
Assignee: nobody → bjacob
blocking2.0: ? → final+
(Assignee)

Comment 4

7 years ago
OK, Implementing the ATI driver blocklist...
(Assignee)

Comment 5

7 years ago
only 1 crash report for this signature last week. shouldn't block.

http://crash-stats.mozilla.com/query/query?product=Firefox&version=ALL%3AALL&branch=2.0&range_value=1&range_unit=weeks&date=12%2F10%2F2010+13%3A10%3A42&query_search=signature&query_type=contains&query=CD3DBase%3A%3AInit%28%29&build_id=&process_type=any&hang_type=any&do_query=1
Severity: critical → normal
blocking2.0: final+ → ?
blocking2.0: ? → -
Crash Signature: [@ CD3DBase::Init() ]

Comment 6

6 years ago
In the past month we have 2 of these on 8.0, 1 on 7.0.1 and 2 on 3.6. This isn't high enough volume to spend time on. Resolving as won't fix and it can be reopened if it spikes up.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.