Problem on display an e-mail writen in Greeks (with html5.enable=true, iso-8859-7 data is converted to utf-8, then Content-Type: charset=iso-8859-7 is applied to the converted utf-8 data)

RESOLVED DUPLICATE of bug 571704

Status

RESOLVED DUPLICATE of bug 571704
8 years ago
8 years ago

People

(Reporter: dev, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b7pre) Gecko/20100927 Firefox/4.0b7pre SeaMonkey/2.1b1pre
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b7pre) Gecko/20100927 Firefox/4.0b7pre SeaMonkey/2.1b1pre

there is a problem with Greek characters when I see an incoming mail. It appears like the charset isn't correct. I tried to change it from View -> Character Encoding from iso8859-7 to UTF-8 and windows 1253 without any luck. When I send an e-mail to myself ( using seamonkey ) I didn't have any problem reading it. Here there are a part of headers/ email that I believe it will help:
From the " bad read " email: 

--------------------------------------------------------------------------
X-MSMail-Priority: Normal
X-Mailer: Microsoft Windows Mail 6.0.6002.18197
X-MimeOLE: Produced By Microsoft MimeOLE V6.0.6002.18197
X-EsetScannerBuild: 7679

This is a multi-part message in MIME format.

------=_NextPart_000_2D01_01CB4072.3713E050
Content-Type: text/plain;
	charset="iso-8859-7"
Content-Transfer-Encoding: quoted-printable

Oi allages einai:

=CA=E1=E9=ED=EF=FD=F1=E9=EF Template
--------------------------------------------------------------------------

From the " good " email that I send it to myself:

--------------------------------------------------------------------------

This is a multi-part message in MIME format.
--------------060104070804060804080105
Content-Type: text/plain; charset=ISO-8859-7; format=flowed
Content-Transfer-Encoding: 8bit

Ελληνικά!

--------------------------------------------------------------------------

In stable versions I don't have any problems to read these e-mails.

Reproducible: Sometimes

Steps to Reproduce:
1. Try to read e-mails with Greek text inside, maybe e-mails send by MS outlook
2.
3.
Actual Results:  
non readable e-mail Greek text

Expected Results:  
readable e-mail Greek text
(Reporter)

Comment 1

8 years ago
Created attachment 479024 [details]
screenshot of email problem

a screenshot that shows how the Greek characters appear

Updated

8 years ago
Component: MailNews: Message Display → Backend
Keywords: regression, regressionwindow-wanted
Product: SeaMonkey → MailNews Core
QA Contact: message-display → backend
Version: unspecified → Trunk

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: Backend → MIME
QA Contact: backend → mime
Resolution: --- → DUPLICATE
Duplicate of bug: 571704
nas, can you check with html5.enable=false?
(Reporter)

Comment 4

8 years ago
thank you for your suggestion Wada, ( ありがと ございます !) ,

when I set html5.enable = false I could read the Greeks from the e-mail that I couldn't - the one on the screenshot!
When I set it back to true , I couldn't. 

Is that something fixable ?
Philip Chee, regression window of this kind of problem is already apparent in other bug - when html5.enable=true is defaulted, and simple workaround is already known by other bugs - html5.enable=false.
Depends on: 571704
Summary: Problem on display an e-mail writen in Greeks → Problem on display an e-mail writen in Greeks (with html5.enable=true, malformed mail, mail data in utf-8 but Content-Type: charset=iso-8859-7, is shown as utf-8 by "Original HTML". Content-Type: charset=iso-8859-7 is ignored)
Duplicate of bug: 598740

Updated

8 years ago
Keywords: regression, regressionwindow-wanted
Mai attached to comment #6 is test mail of bug 598740.
nas, can you produce same problem as yours with the mail?
Can you attach mail produced original problem of comment #0?
Please sort out your check results.
  - Check with what software(Sm, Tb), with which build
  - Check with which mail
  - Check with which html5.enable value
  - Check with which View/Message Body As
> From the " bad read " email: 
> Content-Type: text/plain; charset="iso-8859-7"
> Content-Transfer-Encoding: quoted-printable
> =CA=E1=E9=ED=EF=FD=F1=E9=EF

iso-8859-7
> http://en.wikipedia.org/wiki/ISO/IEC_8859-7
  0xCA 0xE1 0xE9 0xED 0xEF 0xFD 0xF1 0xE9 0xEF
    Κ   α   ι   ν   ο   ύ    ρ   ι   ο
Above Greek chars are written in utf-8 in this bug. If this bug is shown with View/Character Encoding/iso-8859-7, glyph like next is shown and is same as you screen shot.
    Ξ�   Ξ±   ΞΉ   Ξ½   ΞΏ   Ο�    Ο�   ΞΉ   ΞΏ

In screen shot, Content-Type: multipart/alternative; is seen.

With which View/"Message Body As" did you get the scrren shot?
Is there text/html part in the multipart/alternative mail?
If yes, does <meta> tag of http-equiv=Content-Type and content="text/html; charset=iso-8859-7" exists in HTML source of text/html part?
nas, there is no need to attach mail data any more.
Check with attachment 480044 [details] which is attached to bug 598740, please.
Phenomenon/problem depended on View/Message Boy As. As it's still unclear in this bug, tr-open.
Status: RESOLVED → REOPENED
Depends on: 598740
Ever confirmed: true
Resolution: DUPLICATE → ---
Summary: Problem on display an e-mail writen in Greeks (with html5.enable=true, malformed mail, mail data in utf-8 but Content-Type: charset=iso-8859-7, is shown as utf-8 by "Original HTML". Content-Type: charset=iso-8859-7 is ignored) → Problem on display an e-mail writen in Greeks (with html5.enable=true, iso-8859-7 data is converted to utf-8, then Content-Type: charset=iso-8859-7 is applied to the converted utf-8 data)
No longer depends on: 571704
Depends on: 594646
No additional information from bug opener for mail data...
Closing as dup of bug 571704 again.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
No longer depends on: 594646, 598740
Resolution: --- → DUPLICATE
Duplicate of bug: 571704
You need to log in before you can comment on or make changes to this bug.