crash [@ nsCRT::HashCode(unsigned short const*, unsigned int) ]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows XP
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
Build : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100927 Firefox/4.0b7pre

This is new crash signature that first appeared in trunk builds.
Because of the low crash daily rate, the regression range can not be found.
2010083100	1
2010091300	1
2010091700	1
2010091800	1
2010091900	1
2010092200	1
2010092300	1
2010092400	1
2010092500	1
2010092600      1
2010092700	3

Signature	nsCRT::HashCode(unsigned short const*, unsigned int)
UUID	5ee7aec9-0f13-4c55-81f0-6d7292100927
Time 	2010-09-27 09:36:48.912108
Uptime	4112
Last Crash	252080 seconds (2.9 days) before submission
Install Age	4332 seconds (1.2 hours) since version was first installed.
Product	Firefox
Version	4.0b7pre
Build ID	20100927041306
Branch	2.0
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	GenuineIntel family 6 model 13 stepping 6
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x5a04000

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsCRT::HashCode 	xpcom/ds/nsCRT.cpp:249
1 	xul.dll 	nsMappedAttributes::HashValue 	content/base/src/nsMappedAttributes.cpp:183
2 	xul.dll 	PL_DHashTableOperate 	obj-firefox/xpcom/build/pldhash.c:615
3 	mozcrt19.dll 	arena_dalloc_small 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:4153
4 	xul.dll 	nsAttrAndChildArray::Clear 	
5 	xul.dll 	nsAttrAndChildArray::~nsAttrAndChildArray 	
6 	xul.dll 	nsGenericElement::~nsGenericElement 	content/base/src/nsGenericElement.cpp:2106
7 	xul.dll 	nsHTMLIFrameElement::`scalar deleting destructor' 	
8 	xul.dll 	nsNodeUtils::LastRelease 	content/base/src/nsNodeUtils.cpp:295
9 	xul.dll 	nsGenericElement::Release 	content/base/src/nsGenericElement.cpp:4514
10 	xul.dll 	nsCycleCollector::CollectWhite 	xpcom/base/nsCycleCollector.cpp:1896
11 	xul.dll 	nsCycleCollector::FinishCollection 	xpcom/base/nsCycleCollector.cpp:2695
12 	xul.dll 	nsCycleCollector::Collect 	xpcom/base/nsCycleCollector.cpp:2490
13 		@0x788f9f 	
14 	xul.dll 	nsIFrame::BuildDisplayListForChild 	layout/generic/nsFrame.cpp:1691
15 	xul.dll 	nsDisplayBackground::nsDisplayBackground 	layout/base/nsDisplayList.cpp:692

More reports at :
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=nsCRT%3A%3AHashCode%28unsigned%20short%20const*%2C%20unsigned%20int%29&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=nsCRT%3A%3AHashCode%28unsigned%20short%20const*%2C%20unsigned%20int%29

Comment 1

8 years ago
Hrm, it's a bad nsMappedAttributes from ~nsAttrAndChildArray during CC.
Component: XPCOM → DOM
QA Contact: xpcom → general
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsCRT::HashCode(unsigned short const*, unsigned int) ]

Comment 2

7 years ago
Nothing in the past 4 weeks on anything later than 6.0.2. Resolving as works for me.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.