1%/4% Linux Tp4 regression 2010-09-15

RESOLVED WONTFIX

Status

()

Core
Networking
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: karlt, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
1%/4% Linux Tp4 regression 2010-09-15

The regression is 4% on 64-bit Fedora 12

http://mzl.la/dcAah8
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7cf62a2a821e&tochange=69dd0ebbd3bc

On 32-bit Fedora 12, there was only a 1% increase from ~372 to ~384:

http://graphs.mozilla.org/graph.html#tests=[[38,1,411],[38,1,412],[38,1,413],[38,1,414],[38,1,415],[38,1,416],[38,1,417],[38,1,418],[38,1,419],[38,1,420],[38,1,421],[38,1,422],[38,1,423],[38,1,424],[38,1,425],[38,1,426],[38,1,427],[38,1,428],[38,1,429],[38,1,430],[38,1,554],[38,1,555],[38,1,556],[38,1,557],[38,1,558],[38,1,559],[38,1,560],[38,1,561],[38,1,562],[38,1,563],[38,1,564],[38,1,565],[38,1,566],[38,1,567],[38,1,568],[38,1,569],[38,1,570],[38,1,571],[38,1,572],[38,1,573],[38,1,678],[38,1,679],[38,1,680],[38,1,681],[38,1,682],[38,1,683],[38,1,684],[38,1,685],[38,1,686],[38,1,687],[38,1,892],[38,1,893],[38,1,894]]&sel=1284537614,1284679586

with an intersecting range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=77e11b95175f&tochange=10257eea7533

MacOSX 10.6.2 results show a big Tp4 improvement which is clearly in the range

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7cf62a2a821e&tochange=ec6c7ae80489

so it seems likely that bug 594882 or bug 556734 is also involved here.

WINNT 6.1 results may also show an improvement, though it is harder to see
from the graphs.
By 'improvement' you mean that the timing is better or worse?

I believe this is caused by bug 594882, it postpones resume of http channels for a bit and also there has been reintroduced asynchronous cache item obtaining.  Both may slow down, however, the former seems more probable.  I don't immediately think we can do much about it.
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> By 'improvement' you mean that the timing is better or worse?

"improvement" means better.

Things got better on Mac and worse on Linux (as measured by Tp4).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.