The Python server comes in four parts. Current names are: - sync-core: the core, containing the auth backends and some utilities - sync-storage: the Sync APIs - sync-reg: the User APIs - sync-server: the meta-package that combine storage and reg to have something similar to the minimal-server out of the box Having sync as a prefix was a mistake. For hg.mozilla.org/services: we could add a Python prefix to differentiate it from the php server repos. - python-core-server - python-reg-server - python-sync-server - python-full-server
I don't think sync is a mistake. Once we deprecate, it'll just look strange to have the language qualifier. The current names seem fine.
s/sync/services/ maybe? sync-reg is misleading if we're going to use it for non-Sync things. I agree that the language prefix is odd though. Maybe this?: services-server-core services-server-reg services-server-storage services-server-full Or just make server the prefix, since it lives in /services already? Main argument for server-* is that it groups the server pieces...
I agree that services is a bit redundant here, so I am +1 for: - server-core - server-reg - server-storage - server-full For Sync I was thinking it was a mistake because the "Sync API" we implement is just the storage part, so maybe server-storage should be server-sync instead. But either way is fine imo.
I'm actually thinking we want to make the API naming sane, but I want to frame that right.
comment 3 is what we want.
Created hg.m.o/services/server-core hg.m.o/services/server-reg hg.m.o/services/server-storage hg.m.o/services/server-full