Provide option to reveal Sync Key

RESOLVED DUPLICATE of bug 598952

Status

()

RESOLVED DUPLICATE of bug 598952
9 years ago
5 months ago

People

(Reporter: rags, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Our current design with the Sync Key does not mask that field. This decision was made mostly to help reduce errors entering a random 20 character key on mobile devices. 

However, users entering a custom Sync Key (ie secret phrase) are now suddenly looking at their secret phrase in plain view (as we don't mask it). This causes confusion and is generally not a great practice.

Can we provide an option that users can select to reveal the Sync Key, but mask it by default? This would be similar to what OS X does for your WiFi key, for example (thanks to mconnor for that idea, I'd totally forgotten about that). 

We should also do this for Firefox Home and the Fennec UI.
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 598952
(Assignee)

Updated

5 months ago
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.