Migrate all tags to developer tags

VERIFIED FIXED in 5.12.3

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: jbalogh, Assigned: andym)

Tracking

Dependency tree / graph

Details

(Whiteboard: [z][patch])

(Reporter)

Description

7 years ago
Only developers will be able to edit tags, so users_tags_addons is slightly useless.  We only need to link addons to tags; we can infer the creator from the list of add-on devs.  The tag creation should still show up in the add-on's activity log.

Migration script:
1. Tags are now limited to 20 per add-on.  To pick the top 20:
1.1. Take all developer tags ordered by created.
1.2. Fill in up to the limit by taking user tags ordered by user.created. Yes, we're prioritizing tags based on how long the user has been on the site.
1.3. Make sure you're not picking any blacklisted tags.
1.4. Delete the rest.

Schema change:
2. Stop paying attention to user_id in users_tags_addons.  This could involve a schema change to remove the column, or we could make it nullable and pretend it's not there.
(Reporter)

Updated

7 years ago
Blocks: 600688

Updated

7 years ago
Duplicate of this bug: 563069
Duplicate of this bug: 549720
Blocks: 549720
(Assignee)

Updated

7 years ago
Assignee: nobody → amckay
(Assignee)

Comment 3

7 years ago
This is split into two branches the first does the migration and limits the tags down to 20 and changes the database to remove any dupes between addon_id and tag. The second branch removes user_id from the schema and the database and can go 5.13.
(Assignee)

Comment 4

7 years ago
Ready in local branch, will wait for 5.12.3 to roll around.
Whiteboard: [z] → [z][patch]
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 6

7 years ago
-Tags are now limited to 20 per add-on. 

checked  @ https://addons-next.allizom.org/en-US/firefox/addon/46375/
compare to https://addons.mozilla.org/en-US/firefox/addon/46375/

- developer tags get precedence

checked @ https://addons-next.allizom.org/en-US/firefox/addon/8206
compared to https://addons.mozilla.org/en-US/developers/addon/edit/8206/tags

- blacklisted tags 

I haven't seen any blacklisted tags listed for the add-ons I checked. When I blacklisted a listed tag("taobao"), it was removed. On un-blacklisting a tag, it showed up.

- I was able to add/remove tags from the developer pages.

Calling this verified
Status: RESOLVED → VERIFIED

Comment 7

7 years ago
Also checked that 

- Users cannot add tags from add-on detail page for extensions and personas.

- There is no register/log in link under Tags

- There is no Tags section if there are no associated tags

Updated

7 years ago
Depends on: 615132
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.