If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

New mails do not show on Mail window unless you click on GetMsg

VERIFIED DUPLICATE of bug 24594

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED DUPLICATE of bug 24594
17 years ago
13 years ago

People

(Reporter: rpallath, Assigned: racham)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
On Netscape 6 Mail user has an option of indicating how frequently the Mail
message should be retrieved from the server.

1) Invoke  Netscape 6
2) Click on Mail under Tasks menu option
3) Configure your mail server and  point to your IMAP server.
3) Once done, click on 'Mail/New Account Settings' under 'Edit' Menu
4) Choose 'Server' option
5) Check the field "Check for new messages"
6) In the Text field next to the above message enter 1 (minutes)
7) Click 'Ok'

Now send yourself some Test mail.
After around a minute it is supposed to retrieve new mail from the server.

Note the mail icon at the bottom quick icon bar , it goes green (an arrow)
indicating that there is new mail (again, the time taken is usually more than a 
minute).


But the new mail does not show up on the mail header window.
Wait for some more time.(around 3-4 minutes). It still  does not show up.
(If u wait long enough, then eventually it does show up).

But user has to press 'GetMsg' button (at top of browser) to see this new mail.
This is  a very tedious process.
If there is a new mail, it should automatically show up in the header  based on 
the time specified by the user.

The following was used for this build:
       1106 Commercial Build
               [tag: -r Netscape_20000922_BRANCH -D "10/26/2000 10:00:00"
                mozilla source patch: 57725.diffs
                PSM: 1.3 & NSS 3.1 (NSS_3_1_RTM tag)
                PSM jedimind trick: libpsmshim.so
                Cool/AIM: sparc drop 08282000 ,intel drop 10092000
                ns source patch for run-mozilla.sh ]
        1106 Commercial Blackwood Build
               [tag:  -r JAVADEV_PR3_20001002 ]
       1024 Commercial Build gtk libs
       Java Plugin 1.3.0_01 FCS bits

Comment 1

17 years ago
if you start up again does it work? If so this is a dup 24594.

Comment 2

17 years ago
Due to a lack of response I'm going to either assume it's a dup of 24594.
sspitzer also recently fixed another bug this could be a dup of where pop biff
urls weren't being run due to a bad port number.

*** This bug has been marked as a duplicate of 24594 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Marking verified as a duplicate.

Comment 4

17 years ago
I've re-opening this bug. I've looked at bug 24594 and feel that
it's different. If I'm incorrect please let me know and I'll
adjust accordingly. Here's an evaluation and patch from Sergei
who has been working on the problem.

"Evaluation: 

(Sergey Lunegov, St.Petersburg DFS Dev team, email: lsv@sparc.spb.su)

The reason of the bug is the following:
function for loading new messages
is invoked only after button "GetNeMessg" 
was pressed. My suggestion is to
call function "GetNewMessages" every time
another mail folder is selected (it also
includes case of initial opening of mail window)"
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

17 years ago
Created attachment 22663 [details] [diff] [review]
Fix for 60072

Comment 6

17 years ago
reassigning to racham.  Bhuvan, can you try this out and see if this does the
right thing.  This looks like it might be a dup of 60668 which also has a patch
in it.  I haven't looked at it closely though.
Assignee: putterman → racham
Status: REOPENED → NEW
Keywords: patch

Comment 7

17 years ago
I tried out the test case described in this bug report on win NT platform using
mozilla nightly build: 2001041704 and saw the problem to occur. I'm updating the
platform/OS category to win NT for now.
OS: Solaris → Windows NT
Hardware: Sun → PC

Comment 8

17 years ago
I don't seem to see this problem with our 0621 (a.k.a. 6.1 build 42).  

Updated

17 years ago
QA Contact: esther → sheelar
(Assignee)

Comment 9

16 years ago
This is a dup of "Need to restart the app for Biff to be effective" bug 24594.
Marking so.

*** This bug has been marked as a duplicate of 24594 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 10

16 years ago
I am going to verify this based on bhuvan's comments. Thinking that he has 
already checked the patch in here to see if it is the same problem or not as 
mentioned by putterman in the earlier comments.  
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.