Dark horizontal lines appear when scrolling print-preview (invalidation bug)

RESOLVED DUPLICATE of bug 598575

Status

()

Core
Print Preview
RESOLVED DUPLICATE of bug 598575
7 years ago
7 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
STEPS TO REPRODUCE:
 1. Load any page in print-preview -- preferably something multi-page, so you have more to scroll.  e.g. http://ftp.mozilla.org/pub/mozilla.org/ (2 pages long for me)
 2. Scroll up and down. (Either with mousewheel, or uparrow/downarrow, or by clicking the up/down scrollbar buttons, or by dragging the scrollbar)

ACTUAL RESULTS: Dark horizontal lines appear across the page, "scrolled into view", from some sizeable percentage of the scrolling operations.  (that is, I don't get a dark line for every single "tick" of the scroll operation, but I do get a few dark lines every time I scroll)

NOTE: If I *only* scroll by pressing the downarrow key, I get a dark line on every fourth downarrow click.  This leads me to believe this is from rounding error.

NOTE: If I focus the desktop or a different window, the dark lines instantly go away -- so this appears to be an invalidation bug.

Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7pre) Gecko/20100929 Firefox/4.0b7pre
(Reporter)

Comment 1

7 years ago
Created attachment 479629 [details]
screenshot of bug
(Reporter)

Comment 2

7 years ago
Regression range:
20100902044413 dc2939f2640d
20100903030104 4b879b793eb6

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dc2939f2640d&tochange=4b879b793eb6

I'm guessing this is from bug 579276, which had a lot of drawing-related changes, e.g.:
>c888cdffd617	Robert O'Callahan — Bug 579276. Part 12:
>   Clip all drawing to the visible region on the nonretained path. r=cjones
Blocks: 579276
blocking2.0: --- → ?
Same as bug 598575?
(Reporter)

Comment 4

7 years ago
Ah yes, looks like it.
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
blocking2.0: ? → ---
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 598575
You need to log in before you can comment on or make changes to this bug.